dev-libs/keybinder: Fix gtk-doc install location
authorMichał Górny <mgorny@gentoo.org>
Wed, 14 Feb 2018 12:54:13 +0000 (13:54 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 14 Feb 2018 13:34:49 +0000 (14:34 +0100)
Closes: https://bugs.gentoo.org/570972

dev-libs/keybinder/keybinder-0.3.2-r300.ebuild

index a62c8c1c0c786453b5a88d5dea9acc4093cd5744..d12fc21e838bc9ab15af80fd7e1603e0cf6f38dd 100644 (file)
@@ -29,12 +29,18 @@ S=${WORKDIR}/${MY_P}
 
 src_configure() {
        econf \
-               $(use_enable introspection) \
-               --with-html-dir="${EPREFIX}/usr/share/doc/${PF}/html"
+               $(use_enable introspection)
 }
 
 src_install() {
        default
        prune_libtool_files --all
-       dosym /usr/share/doc/${PF}/html/${PN}-3.0 /usr/share/gtk-doc/html/${PN}-3.0
+}
+
+pkg_preinst() {
+       # remove old symlink as otherwise the files will be installed
+       # in the wrong directory
+       if [[ -h ${EROOT%/}/usr/share/gtk-doc/html/keybinder-3.0 ]]; then
+               rm "${EROOT%/}/usr/share/gtk-doc/html/keybinder-3.0" || die
+       fi
 }