app-crypt/rhash: Apply upstream patch to fix 1.3.9 -rc segfault
authorJames Le Cuirot <chewi@gentoo.org>
Thu, 2 Jan 2020 20:38:38 +0000 (20:38 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Thu, 2 Jan 2020 20:38:38 +0000 (20:38 +0000)
Bug: https://github.com/rhash/RHash/issues/104
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
app-crypt/rhash/files/rhash-1.3.9-rc-segfault.patch [new file with mode: 0644]
app-crypt/rhash/rhash-1.3.9-r1.ebuild [moved from app-crypt/rhash/rhash-1.3.9.ebuild with 95% similarity]

diff --git a/app-crypt/rhash/files/rhash-1.3.9-rc-segfault.patch b/app-crypt/rhash/files/rhash-1.3.9-rc-segfault.patch
new file mode 100644 (file)
index 0000000..90a1efe
--- /dev/null
@@ -0,0 +1,25 @@
+From 198e62063ed817357204284a15f95ffc7230044c Mon Sep 17 00:00:00 2001
+From: Aleksey <rhash.admin@gmail.com>
+Date: Thu, 2 Jan 2020 21:16:51 +0300
+Subject: [PATCH] fix segfault on rhash -rc
+
+---
+ file.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/file.c b/file.c
+index 6f593f9..0d18f45 100644
+--- a/file.c
++++ b/file.c
+@@ -361,8 +361,9 @@ int file_init_by_print_path(file_t* file, file_t* prepend_dir, const char* print
+               const char* path = make_path(prepend_dir->real_path, print_path, 0);
+               file_init(file, path, init_flags & ~FileInitReusePath);
+       }
+-      if (!prepend_dir || IS_DOT_STR(prepend_dir->print_path) ||
+-                      (!prepend_dir->print_path && opt.path_separator != ALIEN_PATH_SEPARATOR)) {
++      if (!prepend_dir || (prepend_dir->print_path ?
++                      IS_DOT_STR(prepend_dir->print_path) :
++                      opt.path_separator != ALIEN_PATH_SEPARATOR)) {
+               if ((init_flags & FileInitReusePath) != 0) {
+                       file->print_path = print_path;
+                       file->mode |= FileDontFreePrintPath;
similarity index 95%
rename from app-crypt/rhash/rhash-1.3.9.ebuild
rename to app-crypt/rhash/rhash-1.3.9-r1.ebuild
index 2d4c3303cd5aa11e0e608cc552d44f2d6ebd46e8..e203d68814e20a64a2712c36870b2f897406d881 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -32,6 +32,7 @@ S="${WORKDIR}/RHash-${PV}"
 
 PATCHES=(
        "${FILESDIR}"/${P}-nls.patch
+       "${FILESDIR}"/${P}-rc-segfault.patch
 )
 
 src_prepare() {