media-sound/sidplay: bump EAPI and drop eutils
authorAaron Bauman <bman@gentoo.org>
Sat, 26 May 2018 23:37:19 +0000 (19:37 -0400)
committerAaron Bauman <bman@gentoo.org>
Sun, 27 May 2018 00:15:00 +0000 (20:15 -0400)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

media-sound/sidplay/sidplay-2.0.9.ebuild

index 4f38551f8ebde7d7609c5982e6fa2c8f63100110..982b4bfc55c9bfc31c8754d25458a3aa586fc563 100644 (file)
@@ -1,8 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=2
-inherit eutils
+EAPI=6
 
 DESCRIPTION="C64 SID player"
 HOMEPAGE="http://sidplay2.sourceforge.net/"
@@ -17,12 +16,12 @@ RDEPEND=">=media-libs/libsidplay-2.1"
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-gcc43.patch \
-               "${FILESDIR}"/${P}-gcc44.patch
-}
+PATCHES=(
+       "${FILESDIR}/${P}-gcc43.patch"
+       "${FILESDIR}/${P}-gcc44.patch"
+)
 
 src_install () {
        emake DESTDIR="${D}" install || die "emake install failed"
-       dodoc TODO AUTHORS ChangeLog
+       default
 }