Version bump to compile against older than 2.6.18 kernels and not panic with preempti...
authorMart Raudsepp <leio@gentoo.org>
Fri, 22 Dec 2006 02:12:07 +0000 (02:12 +0000)
committerMart Raudsepp <leio@gentoo.org>
Fri, 22 Dec 2006 02:12:07 +0000 (02:12 +0000)
Package-Manager: portage-2.1.2_rc3-r9

dev-util/sysprof/ChangeLog
dev-util/sysprof/files/digest-sysprof-1.0.8 [new file with mode: 0644]
dev-util/sysprof/metadata.xml
dev-util/sysprof/sysprof-1.0.8.ebuild [new file with mode: 0644]

index d9483a09a5327c5160195d46665a2bc531548617..f6d60cdca1946059f38ea8066a68df5c9b17fe3b 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for dev-util/sysprof
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/ChangeLog,v 1.6 2006/11/09 23:52:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/ChangeLog,v 1.7 2006/12/22 02:12:07 leio Exp $
+
+*sysprof-1.0.8 (22 Dec 2006)
+
+  22 Dec 2006; Mart Raudsepp <leio@gentoo.org> metadata.xml,
+  -sysprof-1.0.6.ebuild, +sysprof-1.0.8.ebuild:
+  Version bump to compile against older than 2.6.18 kernels and not panic with
+  preemptible kernels; remove the kernel panic causing older version; fixes
+  bug 157177. Take over maintenance and add long description
 
 *sysprof-1.0.6 (09 Nov 2006)
 
diff --git a/dev-util/sysprof/files/digest-sysprof-1.0.8 b/dev-util/sysprof/files/digest-sysprof-1.0.8
new file mode 100644 (file)
index 0000000..4b7618b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 4f2e15a81267f668bddd4c551d4a0158 sysprof-1.0.8.tar.gz 137090
+RMD160 e9824a482d594bcaff53054e3f48e15a8be8578f sysprof-1.0.8.tar.gz 137090
+SHA256 ba2141b2acfb19161bf07c93dc5373d1f1e7a53ed2269c8236fd51c6df11728c sysprof-1.0.8.tar.gz 137090
index d9cd2cad66c265328acb729dbfc77f2d0493d0f8..a0aa3980fe63573c01d0c151aedcb661fb85dd5c 100644 (file)
@@ -2,6 +2,12 @@
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
 <maintainer>
-<email>maintainer-needed@gentoo.org</email>
+<email>leio@gentoo.org</email>
 </maintainer>
+<longdescription lang="en">
+       Sysprof is a sampling CPU profiler for Linux that uses a kernel module
+       to profile the entire system, not just a single application.
+       Sysprof handles shared libraries and applications do not need to be recompiled.
+       In fact they don't even have to be restarted.
+</longdescription>
 </pkgmetadata>
diff --git a/dev-util/sysprof/sysprof-1.0.8.ebuild b/dev-util/sysprof/sysprof-1.0.8.ebuild
new file mode 100644 (file)
index 0000000..5dc6f1c
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/sysprof-1.0.8.ebuild,v 1.1 2006/12/22 02:12:07 leio Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://www.daimi.au.dk/~sandmann/sysprof/"
+SRC_URI="http://www.daimi.au.dk/~sandmann/sysprof/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.6
+       x11-libs/pango
+       >=gnome-base/libglade-2"
+
+pkg_setup() {
+       MODULE_NAMES="sysprof-module(misc:${S}/module)"
+       CONFIG_CHECK="PROFILING"
+       PROFILING_ERROR="You need to enable Profiling support in your kernel."
+       BUILD_TARGETS="all"
+       linux-mod_pkg_setup
+}
+
+src_compile() {
+       econf --disable-kernel-module || die
+       emake || die
+       linux-mod_src_compile
+}
+
+src_install() {
+       make install DESTDIR="${D}" || die
+       linux-mod_src_install
+       dodoc AUTHORS ChangeLog NEWS README TODO
+       make_desktop_entry sysprof Sysprof sysprof-icon.png
+}