dev-python/sphinxcontrib-websupport: Bump to 1.2.0
authorMichał Górny <mgorny@gentoo.org>
Mon, 2 Mar 2020 16:19:09 +0000 (17:19 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 2 Mar 2020 20:22:22 +0000 (21:22 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinxcontrib-websupport/Manifest
dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.0.ebuild [new file with mode: 0644]

index 9c05cfb2f57a9fd27cf89ff8411ecee99a3cefcb..bd7b6749a697d5e515bb3994eff8411601274b81 100644 (file)
@@ -1 +1,2 @@
 DIST sphinxcontrib-websupport-1.1.0.tar.gz 587947 BLAKE2B fafaa56071245c8934e27c6d2d7752745b2a8047c8a30d52e513fff7f952086a1b9082aa15e15ef232d69ef0c0d5d117f8a8c97fcdf9cd90c89d53238d7f322e SHA512 adbd7db06150a4424a881a22442c2535ed823c7adcc295ef9c3af5ae38d823349830a114e8a7af2138498d0e68b37189707c1bb5a28b45c76031bcf94210fb89
+DIST sphinxcontrib-websupport-1.2.0.gh.tar.gz 599551 BLAKE2B ffa7561cd0698600d8770227c338e301a00b71f745f6a47aee958830924763522c9e761ab2dc2e77b14404a893374bd84b05bd0e32ff3d08151c554222d05332 SHA512 9b8caf3be0a473e14f8923971eabd99c717f7f0e271bceb83346ba0281eba84a2613b0f1cd3a6181c8e06e650205722ed284e242c31a0a61ea5c9910ece9ed6d
diff --git a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.0.ebuild b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..c0da508
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx websupport extension"
+HOMEPAGE="https://www.sphinx-doc.org
+       https://github.com/sphinx-doc/sphinxcontrib-websupport"
+# pypi tarball is missing templates
+SRC_URI="https://github.com/sphinx-doc/sphinxcontrib-websupport/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+RDEPEND="
+       >=dev-python/six-1.5[${PYTHON_USEDEP}]
+       dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+# avoid circular dependency with sphinx
+PDEPEND="
+       >=dev-python/sphinx-1.5.3[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? (
+               ${PDEPEND}
+               >=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}]
+               >=dev-python/whoosh-2.0[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+       # breaks tests
+       sed -i -e '/pkg_resources/d' \
+               sphinxcontrib/websupport/__init__.py || die
+       distutils-r1_src_prepare
+}
+
+python_compile() {
+       distutils-r1_python_compile
+
+       # missed by setup.py
+       cp -r sphinxcontrib/websupport/templates \
+               "${BUILD_DIR}"/lib/sphinxcontrib/websupport/ || die
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       find "${ED}" -name '*.pth' -delete || die
+}