dev-python/cssutils: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 7 Mar 2020 15:37:56 +0000 (16:37 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 7 Mar 2020 15:37:56 +0000 (16:37 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cssutils/Manifest
dev-python/cssutils/cssutils-1.0.1.ebuild [deleted file]
dev-python/cssutils/cssutils-1.0.2-r1.ebuild [deleted file]
dev-python/cssutils/files/cssutils-1.0.1-pypy-test-backport.patch [deleted file]

index e9f838eecc686d315449840b8cd306759ebaef61..23b7b70e68ac0610a2fb9af4c08f41c06d79170a 100644 (file)
@@ -1,2 +1 @@
-DIST cssutils-1.0.1.tar.gz 353621 BLAKE2B 142320e2358acb1b5b95400f42fb5eb40840602bd204f68a1896ea92b35dfe2ce6f316d84cf5d21a2ef8047f4748294b908057fa12cab352b42d7ab2ffcfaa6f SHA512 932a128443cc31f689d91c7c75a04ddc79824b4e5c0779e48d30fa0a3a760cad82d8208264ec95a3b120c38962f2eabf6b3456aa8f81d24e9c9718e95fd6bf83
 DIST cssutils-1.0.2.tar.gz 367038 BLAKE2B e19edce100dbc05d6e469eb6b0ad234d7d4c9458aca1b2a3e72bdeff1a35dec64427353936a339e2071d8ba2e8804c5754f55a391955a61ef61ae56381269125 SHA512 4988893875a03923d3127e334654799e5c2ebcdc0a7f5b3fb5c9ab27d1b331caa5bf197161312a298531e0757843aa3259ceba5fa19947353eea24a5da53ceda
diff --git a/dev-python/cssutils/cssutils-1.0.1.ebuild b/dev-python/cssutils/cssutils-1.0.1.ebuild
deleted file mode 100644 (file)
index f3e9e62..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A CSS Cascading Style Sheets library"
-HOMEPAGE="https://pypi.org/project/cssutils/ https://bitbucket.org/cthedot/cssutils http://cthedot.de/cssutils/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm ppc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-       )"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-pypy-test-backport.patch
-)
-
-python_prepare_all() {
-       # Disable test failing with dev-python/pyxml installed.
-       if has_version dev-python/pyxml; then
-               sed -e "s/test_linecol/_&/" -i src/tests/test_errorhandler.py
-       fi
-
-       # requires old pbr, does it really?
-       sed \
-               -e '/tests_require/d' \
-               -i setup.py || die
-
-       EPATCH_OPTS="--binary"
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       ln -s "${S}/sheets" "${BUILD_DIR}/sheets" || die
-       # esetup.py test
-       # exclude tests that connect to the network
-       set --  nosetests \
-               -e test_parseUrl -e test_handlers -P "${BUILD_DIR}/lib/cssutils/tests"
-       echo "$@"
-       "$@" || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/cssutils/cssutils-1.0.2-r1.ebuild b/dev-python/cssutils/cssutils-1.0.2-r1.ebuild
deleted file mode 100644 (file)
index 4c06df2..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A CSS Cascading Style Sheets library"
-HOMEPAGE="https://pypi.org/project/cssutils/ https://bitbucket.org/cthedot/cssutils http://cthedot.de/cssutils/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-       )"
-
-python_prepare_all() {
-       # Disable test failing with dev-python/pyxml installed.
-       if has_version dev-python/pyxml; then
-               sed -e "s/test_linecol/_&/" \
-                       -i src/cssutils/tests/test_errorhandler.py \
-                       || die
-       fi
-
-       # requires old pbr, does it really?
-       sed \
-               -e '/tests_require/d' \
-               -i setup.py || die
-
-       # fix casing of call to Windows-1252. Remove when upstream fixes casing.
-       sed -i -e 's/encutils.tryEncodings(test)/encutils.tryEncodings(test).lower()/' \
-       src/cssutils/tests/test_encutils/__init__.py || die "fixing test_encutils failed"
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       ln -s "${S}/sheets" "${BUILD_DIR}/sheets" || die
-       # esetup.py test
-       # exclude tests that connect to the network
-       set --  nosetests \
-               -e test_parseUrl -e test_handlers -P "${BUILD_DIR}/lib/cssutils/tests"
-       echo "$@"
-       "$@" || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/cssutils/files/cssutils-1.0.1-pypy-test-backport.patch b/dev-python/cssutils/files/cssutils-1.0.1-pypy-test-backport.patch
deleted file mode 100644 (file)
index f5f1bda..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# HG changeset patch\r
-# User Daniel <kingdread@gmx.de>\r
-# Date 1448482419 -3600\r
-# Node ID 01a19d494b6f31e91c54ae39c5a6f43f6292a85d\r
-# Parent  3a01bd18118a6466ad93aa23caaa4164528b59ac\r
-Fix tests on PyPy 2\r
-\r
-Tests fail because of the extra "u" prefix in the error message\r
-\r
-diff --git a/src/cssutils/tests/test_profiles.py b/src/cssutils/tests/test_profiles.py\r
---- a/src/cssutils/tests/test_profiles.py\r
-+++ b/src/cssutils/tests/test_profiles.py\r
-@@ -2,6 +2,7 @@\r
- __version__ = '$Id: test_cssvalue.py 1443 2008-08-31 13:54:39Z cthedot $'\r
\r
- import sys\r
-+import platform\r
- import basetest\r
- import cssutils\r
\r
-@@ -124,6 +125,11 @@\r
-             expmsg = u"invalid literal for int(): x" \r
-         elif sys.platform.startswith('java'):\r
-             expmsg = u"invalid literal for int() with base 10: x"\r
-+        # PyPy adds the u prefix, but only in versions lower than Python 3\r
-+        elif (platform.python_implementation() == "PyPy" and\r
-+              sys.version_info < (3, 0)):\r
-+            expmsg = u"invalid literal for int() with base 10: u'x'"\r
-+\r
-             \r
-         self.assertRaisesMsg(Exception, expmsg, \r
-                              cssutils.profile.validate, u'-test-funcval', u'x')\r