media-sound/pulseaudio-modules-bt: import new ebuild
authorJason A. Donenfeld <zx2c4@gentoo.org>
Fri, 4 Jan 2019 13:01:51 +0000 (14:01 +0100)
committerJason A. Donenfeld <zx2c4@gentoo.org>
Fri, 4 Jan 2019 13:19:13 +0000 (14:19 +0100)
Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
media-sound/pulseaudio-modules-bt/metadata.xml [new file with mode: 0644]
media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild [new file with mode: 0644]

diff --git a/media-sound/pulseaudio-modules-bt/metadata.xml b/media-sound/pulseaudio-modules-bt/metadata.xml
new file mode 100644 (file)
index 0000000..38b28ff
--- /dev/null
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>zx2c4@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild
new file mode 100644 (file)
index 0000000..2b9f4ee
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 cmake-utils
+
+DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth (alongside SBC and native+ofono headset)"
+HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/EHfive/${PN}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+       media-libs/fdk-aac
+       virtual/ffmpeg
+       media-libs/sbc
+       >=net-wireless/bluez-5
+       >=sys-apps/dbus-1.0.0
+       >=net-misc/ofono-1.13
+       media-sound/pulseaudio[-bluetooth]
+"
+# Ordinarily media-libs/libldac should be in DEPEND too, but for now upstream repo is using a ldac submodule instead.
+
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+CMAKE_MAKEFILE_GENERATOR="emake"