dev-python/pytest-httpbin: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Fri, 21 Feb 2020 06:47:31 +0000 (07:47 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 21 Feb 2020 10:08:25 +0000 (11:08 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild

index 045e7e10be83c02e69577f4d6bc182f64fcd9718..d2dbd01e477d3a9e72b339c3e94184aa91af9b6e 100644 (file)
@@ -4,6 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
 
 inherit distutils-r1
 
@@ -20,8 +21,6 @@ RDEPEND="
        dev-python/httpbin[${PYTHON_USEDEP}]
        dev-python/six[${PYTHON_USEDEP}]
 "
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]"
 
 PATCHES=(
        "${FILESDIR}"/pytest-httpbin-1.0.0-pypy3-hang.patch