dev-java/openjdk: drop old :11
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 9 May 2019 18:51:07 +0000 (11:51 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 9 May 2019 19:02:25 +0000 (12:02 -0700)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-java/openjdk/Manifest
dev-java/openjdk/openjdk-11.0.2_p7.ebuild [deleted file]

index e3f30ccfa0e2cf1303ce8f519f5553a3464c1535..724c3f51a783971df6d42d75b872327be688b074 100644 (file)
@@ -1,4 +1,3 @@
-DIST jdk-11.0.2+7.tar.bz2 90189455 BLAKE2B 37473a8db4c6ad6789ea67b44f4dda94b9f59143c681a206aa0931b3a2a376fbc480c0c5a6b617072cf9ce1faca34a6c5c5e56cfec9fbf5482b82520fb2463c4 SHA512 03214d9fc920c04f3057594efa78ff588a630e6c594e5bbcc24b4c327fa08273ce060063d98720cdc04bc6978a3d04e172f38ba7a3bcabf02dd5dad397fd9952
 DIST jdk-11.0.3+7.tar.bz2 90300528 BLAKE2B db566140028ddbf9f6e10eaaac018ddf3ad13a954500c73abde8aec5c673c375f2cf0e56bc75c410a4ff90e6cb8e9c4580bb5719786e34865f00a92bd3ea8431 SHA512 46c1c13165e7d5ef480052810ccdc1b5d55f6b2b542e10303d3940536df7f17bf3d8a0cf774e73dc25af7cd69432790656a03c66d2df9efaf71cb9e44c2da684
 DIST openjdk-8.212_p03.tar.bz2 451800 BLAKE2B f8466a0d99650a07e3ff21e8dc06252ef9d31ce15e22c6ede15fc4c7b1633820e84e67aa501e816101c6bd473293fb897645b2df1530d8f7b81c6e8e6d38ce3a SHA512 ccc642da05aa00cfcc46c1eb759391dd2242218b7392bced77481600aa15b3b1d0a0c03380f59b6a6d038311721f249de1a6b116c6f651193cfb57b89fba4866
 DIST openjdk-corba-8.212_p03.tar.bz2 1033709 BLAKE2B f59b294e62425b63e881ed5534ae9beb3cc51351ff197995503671ec52ad82e34e145f8c9790dc88e4f452b4e09af80143fd0f7e0fda588b00eed08d4b2bc861 SHA512 3a786a372ab6b849a6ccd944cdfdc0aa9994a6a9f4d52afccad7d6b187e46a1fd0be30bde3da1eb03988034c36b4590b55379819245fb6f5ed4d75a958e9caa3
diff --git a/dev-java/openjdk/openjdk-11.0.2_p7.ebuild b/dev-java/openjdk/openjdk-11.0.2_p7.ebuild
deleted file mode 100644 (file)
index b03e8a2..0000000
+++ /dev/null
@@ -1,212 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools check-reqs flag-o-matic java-pkg-2 java-vm-2 multiprocessing pax-utils toolchain-funcs
-
-MY_PV=${PV/_p/+}
-SLOT=${MY_PV%%[.+]*}
-
-DESCRIPTION="Open source implementation of the Java programming language"
-HOMEPAGE="https://openjdk.java.net"
-SRC_URI="https://hg.${PN}.java.net/jdk-updates/jdk${SLOT}u/archive/jdk-${MY_PV}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm64 ~ppc64"
-
-IUSE="alsa cups debug doc examples gentoo-vm headless-awt +jbootstrap nsplugin +pch selinux source systemtap +webstart"
-
-CDEPEND="
-       media-libs/freetype:2=
-       sys-libs/zlib
-       systemtap? ( dev-util/systemtap )
-       !headless-awt? (
-               x11-libs/libX11
-               x11-libs/libXext
-               x11-libs/libXi
-               x11-libs/libXrender
-               x11-libs/libXt
-               x11-libs/libXtst
-       )
-"
-
-# cups and alsa required to build, but not to run, make is possible to remove
-RDEPEND="
-       ${CDEPEND}
-       alsa? ( media-libs/alsa-lib )
-       cups? ( net-print/cups )
-       selinux? ( sec-policy/selinux-java )
-"
-
-DEPEND="
-       ${CDEPEND}
-       app-arch/zip
-       media-libs/alsa-lib
-       net-print/cups
-       !headless-awt? (
-               x11-base/xorg-proto
-       )
-       || (
-               dev-java/openjdk-bin:${SLOT}
-               dev-java/openjdk:${SLOT}
-       )
-"
-
-PDEPEND="webstart? ( >=dev-java/icedtea-web-1.6.1:0 )
-       nsplugin? ( >=dev-java/icedtea-web-1.6.1:0[nsplugin] )"
-
-S="${WORKDIR}/jdk${SLOT}u-jdk-${MY_PV}"
-
-# The space required to build varies wildly depending on USE flags,
-# ranging from 2GB to 16GB. This function is certainly not exact but
-# should be close enough to be useful.
-openjdk_check_requirements() {
-       local M
-       M=2048
-       M=$(( $(usex jbootstrap 2 1) * $M ))
-       M=$(( $(usex debug 3 1) * $M ))
-       M=$(( $(usex doc 320 0) + $(usex source 128 0) + 192 + $M ))
-
-       CHECKREQS_DISK_BUILD=${M}M check-reqs_pkg_${EBUILD_PHASE}
-}
-
-pkg_pretend() {
-       openjdk_check_requirements
-       has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}"
-}
-
-pkg_setup() {
-       openjdk_check_requirements
-       java-vm-2_pkg_setup
-
-       JAVA_PKG_WANT_BUILD_VM="openjdk-${SLOT} openjdk-bin-${SLOT}"
-       JAVA_PKG_WANT_SOURCE="${SLOT}"
-       JAVA_PKG_WANT_TARGET="${SLOT}"
-
-       # The nastiness below is necessary while the gentoo-vm USE flag is
-       # masked. First we call java-pkg-2_pkg_setup if it looks like the
-       # flag was unmasked against one of the possible build VMs. If not,
-       # we try finding one of them in their expected locations. This would
-       # have been slightly less messy if openjdk-bin had been installed to
-       # /opt/${PN}-${SLOT} or if there was a mechanism to install a VM env
-       # file but disable it so that it would not normally be selectable.
-
-       local vm
-       for vm in ${JAVA_PKG_WANT_BUILD_VM}; do
-               if [[ -d ${EPREFIX}/usr/lib/jvm/${vm} ]]; then
-                       java-pkg-2_pkg_setup
-                       return
-               fi
-       done
-
-       if has_version --host-root dev-java/openjdk:${SLOT}; then
-               export JDK_HOME=${EPREFIX}/usr/$(get_libdir)/openjdk-${SLOT}
-       else
-               JDK_HOME=$(best_version --host-root dev-java/openjdk-bin:${SLOT})
-               [[ -n ${JDK_HOME} ]] || die "Build VM not found!"
-               JDK_HOME=${JDK_HOME#*/}
-               JDK_HOME=${EPREFIX}/opt/${JDK_HOME%-r*}
-               export JDK_HOME
-       fi
-}
-
-src_prepare() {
-       default
-       chmod +x configure || die
-}
-
-src_configure() {
-       # Work around stack alignment issue, bug #647954. in case we ever have x86
-       use x86 && append-flags -mincoming-stack-boundary=2
-
-       # Enabling full docs appears to break doc building. If not
-       # explicitly disabled, the flag will get auto-enabled if pandoc and
-       # graphviz are detected. pandoc has loads of dependencies anyway.
-       # currently it still bundles lcms libpng giflib and libjpeg.
-
-       local myconf=(
-               --disable-ccache
-               --enable-full-docs=no
-               --with-boot-jdk="${JDK_HOME}"
-               --with-extra-cflags="${CFLAGS}"
-               --with-extra-cxxflags="${CXXFLAGS}"
-               --with-extra-ldflags="${LDFLAGS}"
-               --with-native-debug-symbols=$(usex debug internal none)
-               --with-version-pre=gentoo
-               --with-version-string=${MY_PV%+*}
-               --with-version-build=${MY_PV#*+}
-               --with-zlib=system
-               --enable-dtrace=$(usex systemtap yes no)
-               --enable-headless-only=$(usex headless-awt yes no)
-       )
-
-       # PaX breaks pch, bug #601016
-       if use pch && ! host-is-pax; then
-               myconf+=( --enable-precompiled-headers )
-       else
-               myconf+=( --disable-precompiled-headers )
-       fi
-
-       (
-               unset _JAVA_OPTIONS JAVA JAVAC XARGS
-               CFLAGS= CXXFLAGS= LDFLAGS= \
-               CONFIG_SITE=/dev/null \
-               econf "${myconf[@]}"
-       )
-}
-
-src_compile() {
-       emake -j1 \
-               $(usex jbootstrap bootcycle-images product-images) $(usex doc docs '') \
-               JOBS=$(makeopts_jobs) LOG=debug CFLAGS_WARNINGS_ARE_ERRORS= # No -Werror
-}
-
-src_install() {
-       local dest="/usr/$(get_libdir)/${PN}-${SLOT}"
-       local ddest="${ED}${dest#/}"
-
-       cd "${S}"/build/*-release/images/jdk || die
-
-       # Oracle and IcedTea have libjsoundalsa.so depending on
-       # libasound.so.2 but OpenJDK only has libjsound.so. Weird.
-       if ! use alsa ; then
-               rm -v lib/libjsound.* || die
-       fi
-
-       if ! use examples ; then
-               rm -vr demo/ || die
-       fi
-
-       if ! use source ; then
-               rm -v lib/src.zip || die
-       fi
-
-       dodir "${dest}"
-       cp -pPR * "${ddest}" || die
-
-       use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
-       java-vm_set-pax-markings "${ddest}"
-       java-vm_revdep-mask
-       java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
-
-       if use doc ; then
-               insinto /usr/share/doc/${PF}/html
-               doins -r "${S}"/build/*-release/images/docs/*
-       fi
-}
-
-pkg_postinst() {
-       java-vm-2_pkg_postinst
-
-       if use gentoo-vm ; then
-               ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
-               ewarn "recognised by the system. This will almost certainly break things."
-       else
-               ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
-               ewarn "will not be recognised by the system. For example, simply calling"
-               ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
-               ewarn "fully supports Java ${SLOT}. This JDK must therefore be invoked using its"
-               ewarn "absolute location under ${EPREFIX}/usr/$(get_libdir)/${PN}-${SLOT}."
-       fi
-}