dev-libs/console_bridge: bump to 0.4.2
authorAlexis Ballier <aballier@gentoo.org>
Tue, 8 Jan 2019 08:54:17 +0000 (09:54 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 8 Jan 2019 08:54:33 +0000 (09:54 +0100)
Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-libs/console_bridge/Manifest
dev-libs/console_bridge/console_bridge-0.4.2.ebuild [new file with mode: 0644]

index 598f29ed10f7c189c697fdb537db3515e268f3e5..3b23a7685f7b410ffafcd52b285d5045de9a4e6b 100644 (file)
@@ -1 +1,2 @@
 DIST console_bridge-0.4.0.tar.gz 230398 BLAKE2B 9f8473402d3df14284530be1285b62201fce6d08db7fca6675725fa104bbf929999a2ef84d7a2b7ea12f5645e609447ed7af6e4babe0832d953b3e181ada6071 SHA512 ebfd2ee31bd27380db750e1c40d9f09f50cc7db72f4aceaac9c5bf94894eb8db8ac7cbf67d82cfc27aa154d0e8f2c25ad80b12d06ee90679b5fd6d10fd8d4037
+DIST console_bridge-0.4.2.tar.gz 254013 BLAKE2B 9a02e1a6748c954783615be3242a90a27dd117940dbd5d9a3b5cb1f265ead3c6dc7891a7db2b9f908ce45bc200c50f9e15b5ef1069721d6cc0c9aebd44eb00fe SHA512 21e5d8eaef03512de48189a678318ddc6cb824a99e06885a3185c8316fb1839596c79be4472795b5ffe4be33bf5896b305410fb1144ee979d071e273f66bf532
diff --git a/dev-libs/console_bridge/console_bridge-0.4.2.ebuild b/dev-libs/console_bridge/console_bridge-0.4.2.ebuild
new file mode 100644 (file)
index 0000000..24c3a5e
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/ros/console_bridge"
+fi
+
+inherit ${SCM} cmake-utils multilib
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+       KEYWORDS=""
+       SRC_URI=""
+else
+       KEYWORDS="~amd64 ~arm"
+       SRC_URI="https://github.com/ros/console_bridge/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A ROS-independent package for logging into rosconsole/rosout"
+HOMEPAGE="http://wiki.ros.org/console_bridge"
+LICENSE="BSD"
+SLOT="0/4"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]"
+DEPEND="${RDEPEND}"