dev-util/buildbot-console-view: Version bump
authorBrian Dolbec <dolsen@gentoo.org>
Sun, 17 Jun 2018 10:40:22 +0000 (03:40 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Wed, 27 Jun 2018 15:24:13 +0000 (08:24 -0700)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-util/buildbot-console-view/Manifest
dev-util/buildbot-console-view/buildbot-console-view-1.1.2.ebuild [new file with mode: 0644]

index e1ba8cbb4dc946661471e107cd65281de172e5d4..7716dc48814dbb6ff6b847295f997a712a91510d 100644 (file)
@@ -2,3 +2,4 @@ DIST buildbot-console-view-0.9.12.tar.gz 640923 BLAKE2B cc0da84395aca571803e7326
 DIST buildbot-console-view-0.9.13.tar.gz 640969 BLAKE2B e0c6449c8208a34e568ed632be61fda0ae6ef0b183cd53e2288e1b89e03df6a874ec363f3cfdfa15005bc2913084eaf8640e86abf1ad2d19609e7b4c818f7b77 SHA512 16a3186a97112473fa1f7e811ceffe9f829d6181544e62290172b97b898ddb189fe8e67e223a3e02c936e61fc857a05e0b353dda7e5d4a3ce782f74a32515d2f
 DIST buildbot-console-view-0.9.15.post1.tar.gz 640548 BLAKE2B d28d3fbe40a8ceeaf574d2e8a9a6938664659dc6221a9e7e288c98b771cf7601a8db125dfb3cd71c500aee470a2b476a9daa0d5ec55a83758a96e97e14441def SHA512 42ad7d9dfdf0b3b0cda8d8dcd3fb2bd6734a775755fdc4ebe79d562f5ffb45d0e25d3ece15dec4a7542dd29e45a721e683bec416582901dbfa519c8da76cfa78
 DIST buildbot-console-view-1.1.0.tar.gz 640524 BLAKE2B 038412232299b9dcf5b38c0dcc646bce0f02c817b319bc796268e0bdcd10db0a82dbeb692850ad252246a2a0b48ceca23fd5ac900d46774b64ea19839673f607 SHA512 c45962f73d8e8214518c09fc3163d20f93ac4f55ed547dc90f4116906b94a01384bdc28e52d1b850ba34077c4cd30cd3e1f2dae23c01e233e5745de181e2dc6c
+DIST buildbot-console-view-1.1.2.tar.gz 640509 BLAKE2B 481b8049e606d47be8b171c24a210d6c95ce13ee4a4d46fd689ee836857e8d054f1799ce53de3931f820f02061cdd0c4a47686cd1724fe1c39ab33ca0f274d76 SHA512 23a14d3264802b2cf9a6a7cab0592c6391dc55a8805c17529c3279b129aaab1df97999ffd5fdc0927e7d5fb204e4114b4672018102381523599310cf7223950f
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-1.1.2.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-1.1.2.ebuild
new file mode 100644 (file)
index 0000000..23b0c0a
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-console-view/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+       KEYWORDS=""
+else
+       KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND="
+       ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+       dev-python/mock[${PYTHON_USEDEP}]
+       ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+       >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+       distutils_install_for_testing
+
+       esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+}