dev-python/pastedeploy: Bump to 2.1.0
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 16:45:45 +0000 (18:45 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 16:45:45 +0000 (18:45 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pastedeploy/Manifest
dev-python/pastedeploy/pastedeploy-2.1.0.ebuild [new file with mode: 0644]

index 0b2e277d8514f4b8cf93416631ad863d68b100d7..9d54826cff498358e924a8b4fb02ee9b56adb7e5 100644 (file)
@@ -1 +1,2 @@
 DIST pastedeploy-2.0.1.tar.gz 32215 BLAKE2B a398c54813fa990e3f12ba7c66615e3e84e848ce0dc57177f7f76114a544a11f89569ac85f16afb1ee392a08ad06eb6b4f0cc5aa3f328d154643c541fcafa7bd SHA512 be50c434765d5a913f9456527a72bd88e778e947b1db99ee4ea2f3325366038d941bdab6c826bd61f0c1eb1618395e6bca2081ac99b5ca50aa7120406d5f4ce3
+DIST pastedeploy-2.1.0.tar.gz 32240 BLAKE2B 1672e3b48a287f57e9e7fca082e4cd07cea770db1c2ae0012a83dc8ec927d83bf94461a69c7afdbed082c72506eb46c0c5db15e5f0bc24ad7a4212efb9f6696e SHA512 2c639b5ad07faee013ff3fe37d0e3c6ca7b56ed0960dbcaf133c05d51a7f29d6a2f35118bd8faea4d9aca90438c43d8046a340833878e4b925f32142df169c97
diff --git a/dev-python/pastedeploy/pastedeploy-2.1.0.ebuild b/dev-python/pastedeploy/pastedeploy-2.1.0.ebuild
new file mode 100644 (file)
index 0000000..fd89fee
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="PasteDeploy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Load, configure, and compose WSGI applications and servers"
+HOMEPAGE="https://pypi.org/project/PasteDeploy/"
+# pypi tarball does not include tests
+SRC_URI="https://github.com/Pylons/${PN}/archive/${PV}.tar.gz ->  ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       sed -i 's:"pytest-runner"::' setup.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       use doc && dodoc docs/*.txt
+       find "${D}" -name '*.pth' -delete || die
+}