dev-libs/jsoncpp: Bump to 1.9.3
authorMichał Górny <mgorny@gentoo.org>
Sat, 30 May 2020 07:03:32 +0000 (09:03 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 30 May 2020 07:12:09 +0000 (09:12 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/jsoncpp/Manifest
dev-libs/jsoncpp/jsoncpp-1.9.3.ebuild [new file with mode: 0644]

index 6ad9e4ed08058e294081ee250f3431a152361bb4..7199d75d9783e6ac97ccd30b641295e450e0aa19 100644 (file)
@@ -1,2 +1,3 @@
 DIST jsoncpp-1.9.1.tar.gz 203067 BLAKE2B 654f39b1265b344bb24d3fefb34d4d8b44f69ec819f333f00033ef90acfd5b926fdcc743badf403af797a6f58fe58d195ec0cdf4a1514629f8a1e75c20a6e2f6 SHA512 4a8352e1d32c0ba8a0aea4df1663279cb2256b334643c5b62be37dfb5951e06900ba38c010d1201511fcf7de09137d6a4b886edbb2b99160d2f62b5f4679f766
+DIST jsoncpp-1.9.3.tar.gz 212922 BLAKE2B 6f89762e899ffe127705a30c1fe86f458d62fa05b8dbde6c465c73b6855d3945f3d739ff0c26e1a6326a211c946277908684ace9363df72ba0f460f66b3e3fd8 SHA512 f1c035d54ed952d8d4e41acab5c3ecf6aa445f348f98aeac2e7c89555ec2f6421d727b3bc4c2f54176afce137c545b20d886562901953ec091f91890e91e8559
 DIST jsoncpp-1.9.3_pre20200412.tar.gz 212522 BLAKE2B 17b0cc2ef40ae932c6ff26c0fa77e8326099a1b6f088e53697c2a3c286d23ef63dd372f2ba721025b84670957689251c2d15083bdd24565715a78beac556ead2 SHA512 6e58870c5c478fe2bba125c50c4f77654f304051f4091cc5a98f9a3c9aefbb94d1156eb07ce004a7683675fd971ec825a0828803042d9b03783b1debf3a39e2b
diff --git a/dev-libs/jsoncpp/jsoncpp-1.9.3.ebuild b/dev-libs/jsoncpp/jsoncpp-1.9.3.ebuild
new file mode 100644 (file)
index 0000000..36523a5
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+SRC_URI="
+       https://github.com/open-source-parsers/${PN}/archive/v${PV}.tar.gz
+               -> ${P}.tar.gz"
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0/24"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+       ${PYTHON_DEPS}
+       doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_configure() {
+       local emesonargs=(
+               # Follow Debian, Ubuntu, Arch convention for headers location
+               # bug #452234
+               --includedir include/jsoncpp
+               -Dtests=$(usex test true false)
+       )
+       meson_src_configure
+}
+
+src_compile() {
+       meson_src_compile
+
+       if use doc; then
+               echo "${PV}" > version || die
+               "${EPYTHON}" doxybuild.py --doxygen="${EPREFIX}"/usr/bin/doxygen || die
+               HTML_DOCS=( dist/doxygen/jsoncpp*/. )
+       fi
+}