dev-java/openjdk: add patch to fix build with make-4.3
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 28 Jan 2020 09:21:36 +0000 (01:21 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 28 Jan 2020 09:21:36 +0000 (01:21 -0800)
Bug: https://bugs.gentoo.org/706012
Thanks-to: Alex Parker <alex.iris.parker@gmail.com>
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-java/openjdk/files/openjdk-11-make43.patch [new file with mode: 0644]
dev-java/openjdk/openjdk-11.0.6.ebuild

diff --git a/dev-java/openjdk/files/openjdk-11-make43.patch b/dev-java/openjdk/files/openjdk-11-make43.patch
new file mode 100644 (file)
index 0000000..9466e2b
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/make/common/MakeBase.gmk b/make/common/MakeBase.gmk
+index 170c3ed..b3b49f1 100644
+--- a/make/common/MakeBase.gmk
++++ b/make/common/MakeBase.gmk
+@@ -974,6 +974,7 @@ DependOnVariableFileName = \
+ # Param 2 - (optional) name of file to store value in
+ DependOnVariableHelper = \
+     $(strip \
++        $(eval $(call DependOnVariableFileName, $1, $2):$(NEWLINE)    true) \
+         $(eval -include $(call DependOnVariableFileName, $1, $2)) \
+         $(if $(call equals, $(strip $($1)), $(strip $($1_old))),,\
+           $(call MakeDir, $(dir $(call DependOnVariableFileName, $1, $2))) \
index c5cf008ef3e22c5d6bdff635e9218d31b1a321a3..f98807e652b0d93f468ee6dace43f870158b3a7d 100644 (file)
@@ -73,6 +73,8 @@ PDEPEND="
 
 REQUIRED_USE="javafx? ( alsa !headless-awt )"
 
+PATCHES=( "${FILESDIR}/openjdk-11-make43.patch" )
+
 S="${WORKDIR}/jdk${SLOT}u-jdk-${MY_PV}"
 
 # The space required to build varies wildly depending on USE flags,