dev-python/futures: remove old
authorTim Harder <radhermit@gentoo.org>
Mon, 19 Feb 2018 23:50:40 +0000 (18:50 -0500)
committerTim Harder <radhermit@gentoo.org>
Thu, 1 Mar 2018 19:34:44 +0000 (14:34 -0500)
dev-python/futures/Manifest
dev-python/futures/futures-3.0.3.ebuild [deleted file]

index e6f3221038fea5c162e093777121fb77cb66a0ee..0f527c83e23992948147958d2879e7e13be6bf69 100644 (file)
@@ -1,3 +1,2 @@
-DIST futures-3.0.3.tar.gz 24959 BLAKE2B 2888284e00d6fa6532c19088b058d2b7e153b1df9fde4e004467cb06a64c2c9947d0aa23ecba0171db9c905d0ee6851dde9bc64a276de6a5044453f29c5020fa SHA512 2fa14df90e583ca86c47441b170a93435eb82fd37bb2e15d98e79c32fbe40fc3f602d762805de05fa8007df4a3ce92840915be59481b94ab4863aae884da74bd
 DIST futures-3.1.1.tar.gz 26471 BLAKE2B 53c7678cec213351bc1c172de857c60bbcc392f24a0a6d1fba42eb6190f82d8f01977f8b830e9db5ba0628eb50f2d6dcf0d0421c4b06e42adbd1d429c0c28281 SHA512 7ccb041271ed2688591942f46ab2d2c92d806efbd5209ff9aba77c6d5d3c1a1495fccbeb1718d914894b0b8d936438687e8f3cc22b7ab6625fb518321084ead3
 DIST futures-3.2.0.tar.gz 27320 BLAKE2B b2a6c380955ce29fd434e30897d39d1fe1dbe758ec663bb243c4891849f3e45cf5eba10b71a9e6a028b32f20f876d5662188ec387d442492c7f4b73463b2f728 SHA512 e8c08ebc38d7397b5c2a5dc8c22567af1a1b6d5ce6fb8c189f663fb25b96f1ebcbade1ec0a95e9970dfac73606ecd5d7c6f79cc010fd62930a5b005d9babdde0
diff --git a/dev-python/futures/futures-3.0.3.ebuild b/dev-python/futures/futures-3.0.3.ebuild
deleted file mode 100644 (file)
index b184442..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-inherit distutils-r1
-
-DESCRIPTION="Backport of the concurrent.futures package from Python 3.2"
-HOMEPAGE="https://pypi.python.org/pypi/futures"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       # tests that fail under pypy
-       # https://code.google.com/p/pythonfutures/issues/detail?id=27
-       if [[ "${EPYTHON}" == pypy ]]; then
-               sed -e 's:test_del_shutdown:_&:g' \
-                       -e 's:test_repr:_&:' -i test_futures.py || die
-       fi
-       "${PYTHON}" test_futures.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       local DOCS=( CHANGES )
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}