dev-ros/genpy: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 08:42:39 +0000 (10:42 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 08:42:39 +0000 (10:42 +0200)
Package-Manager: portage-2.2.21

dev-ros/genpy/Manifest [new file with mode: 0644]
dev-ros/genpy/genpy-0.5.5.ebuild [new file with mode: 0644]
dev-ros/genpy/genpy-9999.ebuild [new file with mode: 0644]
dev-ros/genpy/metadata.xml [new file with mode: 0644]

diff --git a/dev-ros/genpy/Manifest b/dev-ros/genpy/Manifest
new file mode 100644 (file)
index 0000000..e49a495
--- /dev/null
@@ -0,0 +1 @@
+DIST genpy-0.5.5.tar.gz 59514 SHA256 4727b5c176e94abd3fa4c2f3ce2b2b6d84ca7cb638a8899202a495a0f416df85 SHA512 f79e7ccf2ff6aba672ccbbf0a3ea9ac3c722d2eff5be5fcb71dcd345b45ad8dfde6db4b866bc2bc63707f377cef8757ebf6de61bf25599752360ae0c35dfada9 WHIRLPOOL 41fd1aa9a530fec161986994c12d240732d66e1014b8e8118b7296a33041e23042b0fd69a13fe580397147a37d7b3cf1e3c2371d2a1edf402f49c8d8403406ab
diff --git a/dev-ros/genpy/genpy-0.5.5.ebuild b/dev-ros/genpy/genpy-0.5.5.ebuild
new file mode 100644 (file)
index 0000000..6f7df14
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/genpy"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit ros-catkin
+
+DESCRIPTION="Python ROS message and service generators"
+HOMEPAGE="http://wiki.ros.org/genpy"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE="test"
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
diff --git a/dev-ros/genpy/genpy-9999.ebuild b/dev-ros/genpy/genpy-9999.ebuild
new file mode 100644 (file)
index 0000000..46b7961
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/genpy"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit ros-catkin
+
+DESCRIPTION="Python ROS message and service generators"
+HOMEPAGE="http://wiki.ros.org/genpy"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/pyyaml[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+       )
+"
diff --git a/dev-ros/genpy/metadata.xml b/dev-ros/genpy/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>