x11-wm/e16: version bump
authorAndrew Savchenko <bircoph@gentoo.org>
Sat, 21 Dec 2019 22:57:21 +0000 (01:57 +0300)
committerAndrew Savchenko <bircoph@gentoo.org>
Sat, 21 Dec 2019 23:26:58 +0000 (02:26 +0300)
Closes: https://bugs.gentoo.org/703432
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
x11-wm/e16/Manifest
x11-wm/e16/e16-1.0.21.ebuild [new file with mode: 0644]

index d8db06d04e1ea83325f9df45f85be4b3499a50da..6c18ee1051d42f8c81ad1e1eff874ef4a802ee4c 100644 (file)
@@ -1,2 +1,3 @@
 DIST e16-1.0.19.tar.xz 1433016 BLAKE2B 9c27dd6a8d78d2f765b495e5398041a30bf939a5d3926f9f07e022c9bbbc70716b072e40beb6592159f896cc7a15e2fd4e25c8a07db333a80fc8156a82dce357 SHA512 9dc66a4224eacde92c567f9f5b029f21543675207b782077e25f3082ef2133a547eb955fc877b01b2200d99c26148f54a6b59f1ba191163760ecf3b32d5dd374
 DIST e16-1.0.20.tar.xz 1438516 BLAKE2B 32800ed079eb3c51c34277fa5d49ef7a892c0ccd5956f5f7eb7c34ab2e223fe7a5033b35d53402fa4a18283261a767ac692a5bfa08b46d5ea2a4e5195c656fed SHA512 798225dcfad266febe0911aeeac1a57256c45071e72ed326ae2081efdcf0d110e951f41badf5ece92dd0a40f5e342f80035e46d3c2435eb2f32a08c556893612
+DIST e16-1.0.21.tar.xz 1440484 BLAKE2B ea9521d4939400e292e9e2be6e73770a48d966702897c30babfe036a655ef3c5d9766eca3867e1a84b8fbd934a05c4a0487239a78d641c41a6e93a19feeb70a2 SHA512 0f5984d3c3594bf94338c9b53c681cd40f8cc165a18d7d9e0e6202fdf237ace52d9aac9c5ba04f052f94dfd463dcf558b8015044b4d457114c19a7a27ac23723
diff --git a/x11-wm/e16/e16-1.0.21.ebuild b/x11-wm/e16/e16-1.0.21.ebuild
new file mode 100644 (file)
index 0000000..5d940a1
--- /dev/null
@@ -0,0 +1,129 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Enlightenment Window Manager (E16)"
+HOMEPAGE="https://www.enlightenment.org https://sourceforge.net/projects/enlightenment/"
+SRC_URI="mirror://sourceforge/enlightenment/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="audiofile container dbus debug +dialogs doc examples gnome
+libhack modules nls opengl +pango sndfile sound +themes xcomposite
++xft xi2 xinerama xpresent +xrandr +xrender +xsm +xsync zoom"
+
+REQUIRED_USE="
+       audiofile? ( sound )
+       opengl? ( xcomposite )
+       sndfile? ( sound )
+       sound? ( ^^ ( sndfile audiofile ) )
+"
+
+BDEPEND="
+       nls? ( sys-devel/gettext )
+       virtual/pkgconfig
+"
+COMMON_DEPEND="
+       media-libs/freetype:2
+       media-libs/imlib2[X]
+       virtual/libiconv
+       x11-libs/libX11
+       x11-libs/libXext
+       x11-misc/xbitmaps
+       dbus? ( sys-apps/dbus )
+       opengl? (
+               media-libs/glu
+               media-libs/mesa
+       )
+       pango? (
+               dev-libs/glib:2
+               x11-libs/pango[X]
+       )
+       sound? (
+               || (
+                       media-sound/apulse[sdk]
+                       media-sound/pulseaudio
+               )
+               sndfile? ( media-libs/libsndfile )
+               audiofile? ( media-libs/audiofile:= )
+       )
+       xcomposite? (
+               x11-libs/libXcomposite
+               x11-libs/libXdamage
+               x11-libs/libXfixes
+       )
+       xft? ( x11-libs/libXft )
+       xinerama? ( x11-libs/libXinerama )
+       xpresent? ( x11-libs/libXpresent )
+       xrandr? ( x11-libs/libXrandr )
+       xrender? ( x11-libs/libXrender )
+       xsm? (
+               x11-libs/libICE
+               x11-libs/libSM
+       )
+       zoom? ( x11-libs/libXxf86vm )
+"
+RDEPEND="${COMMON_DEPEND}
+       doc? ( app-doc/e16-docs )
+       nls? ( virtual/libintl )
+       themes? ( x11-themes/e16-themes )
+       !x11-wm/enlightenment:0
+"
+DEPEND="${COMMON_DEPEND}
+       x11-base/xorg-proto
+"
+
+PATCHES=( "${FILESDIR}/${PN}-user-fonts.patch" )
+
+src_configure() {
+       local myconf=(
+               $(use_enable container)
+               $(use_enable dbus)
+               $(use_enable debug libtrip)
+               $(use_enable dialogs)
+               $(use_enable doc docs)
+               $(use_enable libhack)
+               $(use_enable modules)
+               $(use_enable nls)
+               $(use_enable opengl glx)
+               $(use_enable pango)
+               $(use_enable sound sound pulseaudio)
+               $(use_enable xcomposite composite)
+               $(use_enable xft)
+               $(use_enable xi2)
+               $(use_enable xinerama)
+               $(use_enable xpresent)
+               $(use_enable xrandr)
+               $(use_enable xrender)
+               $(use_enable xsm sm)
+               $(use_enable xsync)
+               $(use_enable zoom)
+               $(use_with audiofile sndldr audiofile)
+               $(use_with gnome gnome gnome3)
+               $(use_with sndfile sndldr sndfile)
+               --enable-mans
+               --disable-docs
+               --disable-esdtest
+               --disable-gcc-cpp
+               --disable-hints-gnome
+               --disable-werror
+               --disable-xscrnsaver
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+       docompress -x /usr/share/doc/${PF}/e16.html
+       dodoc COMPLIANCE docs/e16.html
+       use examples && dodoc -r sample-scripts
+}
+
+pkg_postinst() {
+       einfo "In order to use custom fonts, put them into ~/.e16/fonts/ and use"
+       einfo "appropriate names in ~/.e16/fonts.cfg. \"Use theme font configuration\""
+       einfo "in the Theme setting should be disabled for this to work."
+}