dev-python/columnize: Fix setup.py to use tests_requires and correct deps to pytest
authorJustin Lecher <jlec@gentoo.org>
Mon, 28 Sep 2015 12:26:18 +0000 (14:26 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 28 Sep 2015 12:26:24 +0000 (14:26 +0200)
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=539818
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=561734

see Github rocky/pycolumnize#24

Package-Manager: portage-2.2.22
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/columnize/columnize-0.3.5-r1.ebuild
dev-python/columnize/columnize-0.3.8.ebuild
dev-python/columnize/files/columnize-0.3.5-nose.patch [new file with mode: 0644]
dev-python/columnize/files/columnize-0.3.8-nose.patch [new file with mode: 0644]

index 4d71319180a49b21fc19775ee728e549122e4d82..579c0a26494f80a524ba276d997d20a8c9c2d6f9 100644 (file)
@@ -20,6 +20,8 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/nose[${PYTHON_USEDEP}] )"
 RDEPEND=""
 
+PATCHES=( "${FILESDIR}"/${P}-nose.patch )
+
 python_test() {
        nosetests || die "tests failed"
 }
index 54782b71ab6b600906eaa34924a1facd4336dd06..5d94ec2b761a84b23c59858e2b55ea4c4ae5a371 100644 (file)
@@ -22,6 +22,8 @@ DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
 
+PATCHES=( "${FILESDIR}"/${P}-nose.patch )
+
 python_test() {
        py.test || die
 }
diff --git a/dev-python/columnize/files/columnize-0.3.5-nose.patch b/dev-python/columnize/files/columnize-0.3.5-nose.patch
new file mode 100644 (file)
index 0000000..f09f770
--- /dev/null
@@ -0,0 +1,15 @@
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index e1035eb..bb8eaf6 100755
+--- a/setup.py
++++ b/setup.py
+@@ -26,6 +26,6 @@ setup(
+       url                = web,
+       version            = VERSION,
+       py_modules         = py_modules,
+-      setup_requires     = ['nose>=1.0'],
++      tests_requires     = ['nose>=1.0'],
+       zip_safe           = zip_safe
+       )
diff --git a/dev-python/columnize/files/columnize-0.3.8-nose.patch b/dev-python/columnize/files/columnize-0.3.8-nose.patch
new file mode 100644 (file)
index 0000000..956e033
--- /dev/null
@@ -0,0 +1,15 @@
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 4a4b238..854d3e1 100755
+--- a/setup.py
++++ b/setup.py
+@@ -33,6 +33,6 @@ setup(
+       version            = VERSION,
+       py_modules         = py_modules,
+       install_requires   = install_requires,
+-      setup_requires     = ['nose>=1.0'],
++      tests_requires     = ['pytest'],
+       zip_safe           = zip_safe
+       )