+++ /dev/null
---- Makefile.in 2009-04-27 05:33:50.000000000 +0200
-+++ Makefile.in.new 2009-10-11 15:22:23.458985416 +0200
-@@ -44,7 +44,7 @@
- cygwin_procstat.cpp cygwin_rendercpupagestat.cpp \
- lib/routines.cpp lib/timeRoutines.cpp lib/prettyPrint.cpp \
- Makefile
-- $(CXX) $(CFLAGS) $(LDFLAGS) procinfo.cpp -o $@
-+ $(CXX) $(CFLAGS) $(LDFLAGS) procinfo.cpp -o $@ $(LIBS)
-
- #procinfo.o: procinfo.cpp procinfo.h
- # $(XX) $(CFLAGS) procinfo.cpp -o procinfo.o
--- /dev/null
+--- a/configure.in
++++ b/configure.in
+@@ -37,13 +37,9 @@
+ AC_ARG_ENABLE(maintainer-mode, [ --enable-maintainer-mode Enables debug symbols and disables optimizations [default=no]],
+ [ enable_maintainer_mode=yes ])
+
+-if test "$enable_maintainer_mode" = "yes"; then
+- CFLAGS="-O0 -g3 --pipe -Wall"
+- LDFLAGS="-lncurses"
+-else
+- CFLAGS="$CFLAGS -pipe -Wall"
+- LDFLAGS="-s -lncurses"
+-fi
++CXXFLAGS+=" -Wall"
++
++PKG_CHECK_MODULES([NCURSES], [ncurses])
+
+ AC_OUTPUT(Makefile)
+ #AC_CONFIG_FILES([Makefile])
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -6,24 +6,30 @@
+
+ mandir= @mandir@
+
++CC = @CC@
+ CXX = @CXX@
+
+ CFLAGS = @CFLAGS@
++CXXFLAGS = @CXXFLAGS@
++
+ LDFLAGS = @LDFLAGS@
+
++CPPFLAGS += @NCURSES_CFLAGS@
++LIBS = @NCURSES_LIBS@
++
+ #LDLIBS = -levent
+
+ ### Add to taste:
+
+-# CFLAGS = -g
++# CXXFLAGS = -g
+ # LDFLAGS = -g
+
+-# CFLAGS += -DPROC_DIR=\"extra2/\"
++# CXXFLAGS += -DPROC_DIR=\"extra2/\"
+
+-# CFLAGS += -DDEBUG
++# CXXFLAGS += -DDEBUG
+ # LDLIBS += -ldmalloc
+
+-# CFLAGS += -pg
++# CXXFLAGS += -pg
+ # LDFLAGS = -pg
+
+ ### End of configurable options.
+@@ -44,10 +50,10 @@
+ cygwin_procstat.cpp cygwin_rendercpupagestat.cpp \
+ lib/routines.cpp lib/timeRoutines.cpp lib/prettyPrint.cpp \
+ Makefile
+- $(CXX) $(CFLAGS) $(LDFLAGS) procinfo.cpp -o $@
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) procinfo.cpp -o $@ $(LIBS)
+
+ #procinfo.o: procinfo.cpp procinfo.h
+-# $(XX) $(CFLAGS) procinfo.cpp -o procinfo.o
++# $(CXX) $(CXXFLAGS) procinfo.cpp -o procinfo.o
+
+ install: procinfo procinfo.8
+ -mkdir -p $(DESTDIR)/$(prefix)/bin
---- procinfo-ng-2.0.217/procinfo.8.orig 2009-01-11 11:21:23.000000000 +0100
-+++ procinfo-ng-2.0.217/procinfo.8 2009-01-11 11:21:48.000000000 +0100
+--- a/procinfo.8
++++ b/procinfo.8
@@ -6,7 +6,7 @@
.SH SYNOPSIS
.B procinfo
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils toolchain-funcs
+inherit autotools
DESCRIPTION="Completely rewrite of the old system monitoring app procinfo"
HOMEPAGE="https://sourceforge.net/projects/procinfo-ng/"
LICENSE="|| ( GPL-2 LGPL-2.1 )"
SLOT="0"
KEYWORDS="amd64 hppa x86"
-IUSE=""
RDEPEND="
sys-libs/ncurses:0=
!app-admin/procinfo"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-autotools.patch
"${FILESDIR}"/${P}-man.patch
)
src_prepare() {
- epatch "${PATCHES[@]}"
- # removing -s flag as portage does the stripping part and add support
- # for custom LDFLAGS. Plus correct for --as-needed
- sed \
- -e 's:-s -lncurses:${LDFLAGS}:' \
- -i configure.in || die "sed configure.in failed"
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
-
-src_compile() {
- emake LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"
-}