Development branch version bump.
authorDenis Dupeyron <calchan@gentoo.org>
Tue, 10 Oct 2006 09:20:13 +0000 (09:20 +0000)
committerDenis Dupeyron <calchan@gentoo.org>
Tue, 10 Oct 2006 09:20:13 +0000 (09:20 +0000)
Package-Manager: portage-2.1.2_pre2-r7

sci-electronics/xcircuit/ChangeLog
sci-electronics/xcircuit/files/digest-xcircuit-3.6.59 [new file with mode: 0644]
sci-electronics/xcircuit/xcircuit-3.6.59.ebuild [new file with mode: 0644]

index 6febe6996f9676fef24d35faded0772941aa310a..9b81754e001efbec4abf664a6263876af04a41d2 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sci-electronics/xcircuit
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.24 2006/10/01 20:36:58 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.25 2006/10/10 09:20:13 calchan Exp $
+
+*xcircuit-3.6.59 (10 Oct 2006)
+
+  10 Oct 2006; Denis Dupeyron <calchan@gentoo.org> -xcircuit-3.6.58.ebuild,
+  +xcircuit-3.6.59.ebuild:
+  Development branch version bump.
 
   01 Oct 2006; Denis Dupeyron <calchan@gentoo.org> -xcircuit-3.4.21.ebuild,
   -xcircuit-3.6.41.ebuild:
diff --git a/sci-electronics/xcircuit/files/digest-xcircuit-3.6.59 b/sci-electronics/xcircuit/files/digest-xcircuit-3.6.59
new file mode 100644 (file)
index 0000000..173840e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 2dcf228f45f1c473bd56f27ba35f4b54 xcircuit-3.6.59.tgz 1422740
+RMD160 cea8b278ba3e6c7b59dd3a001c5453743e1d29f1 xcircuit-3.6.59.tgz 1422740
+SHA256 855c2daf796ff0d22383cbe12da754d075ce3f35848f672fd238830f8ae5f2d9 xcircuit-3.6.59.tgz 1422740
diff --git a/sci-electronics/xcircuit/xcircuit-3.6.59.ebuild b/sci-electronics/xcircuit/xcircuit-3.6.59.ebuild
new file mode 100644 (file)
index 0000000..b9abd75
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.6.59.ebuild,v 1.1 2006/10/10 09:20:13 calchan Exp $
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
+HOMEPAGE="http://opencircuitdesign.com/xcircuit"
+
+# This is a development version. Do not keyword without contacting maintainer as we add/remove these at random.
+KEYWORDS="-*"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+# Disable tests, see bug #131024
+RESTRICT="test"
+
+DEPEND="virtual/ghostscript
+       dev-lang/tk
+       || ( x11-libs/libXt
+            virtual/x11
+       )"
+
+src_compile() {
+       econf \
+       --with-tcl \
+       --with-ngspice \
+       --disable-dependency-tracking \
+       || die 'econf failed!'
+       emake || die 'emake failed!'
+}
+
+src_install () {
+       make DESTDIR=${D} install || die "Installation failed"
+       dodoc CHANGES README* TODO
+
+       doman ${D}/usr/lib/xcircuit-3.6/man/xcircuit.1
+       rm ${D}/usr/lib/xcircuit-3.6/man -rf
+}
+
+src_postinst() {
+       ewarn "You may want to emerge ng-spice-rework which integrates well with xcircuit."
+       ewarn "Note that in order for ngspice to work with xcircuit, you'll need at least"
+       ewarn "sci-electronics/ng-spice-rework-17-r1."
+}