app-office/auto-multiple-choice: New package, bug 501254
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 21 Jan 2017 00:07:58 +0000 (01:07 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 21 Jan 2017 21:15:26 +0000 (22:15 +0100)
Thanks to Nicolas Pujol, Maxim Koltsov, and Pierre-Olivier Vallès for their work

app-office/auto-multiple-choice/Manifest [new file with mode: 0644]
app-office/auto-multiple-choice/auto-multiple-choice-1.3.0.ebuild [new file with mode: 0644]
app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-conf.patch [new file with mode: 0644]
app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-desktop.patch [new file with mode: 0644]
app-office/auto-multiple-choice/metadata.xml [new file with mode: 0644]

diff --git a/app-office/auto-multiple-choice/Manifest b/app-office/auto-multiple-choice/Manifest
new file mode 100644 (file)
index 0000000..71cb7ef
--- /dev/null
@@ -0,0 +1 @@
+DIST auto-multiple-choice_1.3.0_sources.tar.gz 4328255 SHA256 682e8a3530f5948b6e3d42b1c54ab4f0449f815dd80947a3f8528a7143a42c0a SHA512 fcfacd071072f5773556c706b6fa0aea4ff3f3752f3a1f40c9e6de7ec870e939adc57e6bd4c90cac80241cc798e02a71c9fc80d9ccf25ad3a10752f937d06da5 WHIRLPOOL 6a7f22565a2d5515ef19355d426af13b664921b3efe94bad0e347c3c0fb7413d09ba9c501eaa215fd9fc148a41ebdc26bd6472cccd935ba796a3d40060ce4315
diff --git a/app-office/auto-multiple-choice/auto-multiple-choice-1.3.0.ebuild b/app-office/auto-multiple-choice/auto-multiple-choice-1.3.0.ebuild
new file mode 100644 (file)
index 0000000..bbb3615
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+inherit toolchain-funcs perl-functions latex-package
+
+DESCRIPTION="Create and manage multiple choice questionnaries, including automated marking"
+HOMEPAGE="http://home.gna.org/auto-qcm/"
+SRC_URI="http://download.gna.org/auto-qcm/${PN}_${PV}_sources.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+CDEPEND="
+       app-text/texlive[doc,dvi2tty,dvipdfm,extra,graphics,png,pstricks,science,truetype,xml,X,luatex,xetex,humanities,omega,publishers,l10n_fr]
+       app-text/poppler:=
+       dev-perl/XML-LibXML
+       media-libs/netpbm
+       media-libs/opencv
+"
+DEPEND="${CDEPEND}
+       app-text/dblatex
+       app-text/docbook-xml-simple-dtd:*
+       app-text/docbook-xsl-stylesheets
+"
+RDEPEND="${CDEPEND}
+       dev-lang/perl:=
+       dev-perl/gtk2-perl
+       dev-perl/Gtk2-Notify
+       media-gfx/imagemagick
+       dev-perl/XML-Writer
+       dev-perl/Archive-Zip
+       dev-perl/DBI
+       dev-perl/Text-CSV
+       dev-perl/DBD-SQLite
+       dev-perl/Net-CUPS
+       dev-perl/Email-Address
+       dev-perl/Email-MIME
+       dev-perl/Email-Sender
+"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-1.3.0-desktop.patch"
+       "${FILESDIR}/${PN}-1.3.0-conf.patch"
+)
+
+src_compile() {
+       perl_set_version
+       export VENDOR_LIB PVR
+       export TEXINPUTS="/usr/share/dblatex/latex/style:/usr/share/dblatex/latex/misc:/usr/share/dblatex/latex/graphics:"
+
+       export MAKEOPTS="-j1"
+       # when doing a parallel build, the package is acting decidedly odd
+       # e.g., the build seems to succeed while actually stuff fails
+       # and subsequent error messages do not have any relation to the real problem
+       # So let's keep this also for easier debugging
+
+       emake \
+                       GCC_NETPBM="-I/usr/include/netpbm/ -lnetpbm" \
+                       GCC="$(tc-getCC)" \
+                       GCC_PP="$(tc-getCXX)"
+}
+
+src_install() {
+       default
+}
diff --git a/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-conf.patch b/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-conf.patch
new file mode 100644 (file)
index 0000000..2e5e0cd
--- /dev/null
@@ -0,0 +1,54 @@
+diff -ruN auto-multiple-choice-1.3.0.orig/Makefile.conf auto-multiple-choice-1.3.0/Makefile.conf
+--- auto-multiple-choice-1.3.0.orig/Makefile.conf      2016-03-09 20:17:01.000000000 +0100
++++ auto-multiple-choice-1.3.0/Makefile.conf   2017-01-21 21:55:32.649670839 +0100
+@@ -33,13 +33,13 @@
+ # directory for executable
+ BINDIR=/usr/bin
+ # directory for perl modules
+-PERLDIR=/usr/share/perl5
++PERLDIR=$(VENDOR_LIB)
+ # directory for some AMC executables, not to be used by end-user
+ MODSDIR=/usr/lib/AMC
+ # directory for LaTeX style file
+-TEXDIR=/usr/share/texmf/tex/latex/AMC
++TEXDIR=/usr/share/texmf-site/tex/latex/AMC
+ # directory for LaTeX doc
+-TEXDOCDIR=/usr/share/doc/texmf/AMC/
++TEXDOCDIR=/usr/share/texmf-site/doc/AMC/
+ # directory for man (1) files
+ MAN1DIR=/usr/share/man/man1
+ # directory for desktop file 
+@@ -54,7 +54,7 @@
+ # directory for AMC packaged models
+ MODELSDIR=/usr/share/auto-multiple-choice/models
+ # directory for documentation (will use html/auto-multiple-choice.* subdirs for HTML docs)
+-DOCDIR=/usr/share/doc/auto-multiple-choice-doc
++DOCDIR=/usr/share/doc/$(PVR)
+ # directory for Shared MIME-info Database
+ SHARED_MIMEINFO_DIR=/usr/share/mime/packages
+@@ -91,8 +91,8 @@
+ # INSTALL USER AND GROUP
+-ifneq ($(SYSTEM_TYPE),rpm)
+-INSTALL_USER=root
+-INSTALL_GROUP=root
+-endif
++#ifneq ($(SYSTEM_TYPE),rpm)
++#INSTALL_USER=root
++#INSTALL_GROUP=root
++#endif
+diff -ruN auto-multiple-choice-1.3.0.orig/doc/Makefile auto-multiple-choice-1.3.0/doc/Makefile
+--- auto-multiple-choice-1.3.0.orig/doc/Makefile       2016-03-14 19:40:45.000000000 +0100
++++ auto-multiple-choice-1.3.0/doc/Makefile    2017-01-21 21:28:29.438603307 +0100
+@@ -64,7 +64,7 @@
+        esac
+ %.pdf: %.tex $(BLOCK_IMAGES:.svg=.pdf)
+-      export TEXINPUTS=./img_pdf/: ; case $< in \
++      export TEXINPUTS=$(TEXINPUTS):./img_pdf/: ; case $< in \
+         *.ja.tex) \
+             sed -i -e '/setuplocale/a\
+ \\usepackage{xeCJK}\
diff --git a/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-desktop.patch b/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-desktop.patch
new file mode 100644 (file)
index 0000000..3c6225d
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/auto-multiple-choice.desktop.in-old      2014-02-11 20:25:42.995456713 +0100
++++ b/auto-multiple-choice.desktop.in  2014-02-11 20:25:54.972456566 +0100
+@@ -10,5 +10,5 @@
+ GenericName[fr]=QCM automatique
+ Comment=Manage multiple choice questionnaires, with automatic marking from papers' scans
+ Comment[fr]=Conception et correction automatique de QCM en LaTeX
+-Keywords=multiple;choice;questionnaire;exam;grading;marking;MCQ;AMC
+-Keywords[fr]=questionnaire;choix;multiple;examen;correction;QCM;AMC
++Keywords=multiple;choice;questionnaire;exam;grading;marking;MCQ;AMC;
++Keywords[fr]=questionnaire;choix;multiple;examen;correction;QCM;AMC;
diff --git a/app-office/auto-multiple-choice/metadata.xml b/app-office/auto-multiple-choice/metadata.xml
new file mode 100644 (file)
index 0000000..b9e2049
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>office@gentoo.org</email>
+    <name>Gentoo Office project</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>perl@gentoo.org</email>
+    <name>Gentoo Perl project</name>
+  </maintainer>
+  <maintainer type="person">
+    <email>nibheis@gmail.com</email>
+    <name>Pierre-Olivier Vallès</name>
+  </maintainer>
+</pkgmetadata>