dev-util/serialtalk: Bump to EAPI 7 and cmake.eclass.
authorOliver Freyermuth <o.freyermuth@googlemail.com>
Sun, 3 May 2020 20:21:26 +0000 (22:21 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 4 May 2020 17:26:08 +0000 (20:26 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Closes: https://github.com/gentoo/gentoo/pull/15633
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-util/serialtalk/serialtalk-1.2-r1.ebuild [new file with mode: 0644]
dev-util/serialtalk/serialtalk-9999.ebuild

diff --git a/dev-util/serialtalk/serialtalk-1.2-r1.ebuild b/dev-util/serialtalk/serialtalk-1.2-r1.ebuild
new file mode 100644 (file)
index 0000000..db77b5e
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/BGO-OD/serialtalk.git"
+else
+       SRC_URI="https://github.com/BGO-OD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simple command-line tool to talk to serial devices"
+HOMEPAGE="https://github.com/BGO-OD/serialtalk"
+
+LICENSE="GPL-3+"
+SLOT="0"
index 59c9ad0a3efd0e718c132ed7d813a33d84d4b29b..0943a8aaeff852160265385960e00310cd13519e 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 if [[ ${PV} == 9999 ]]; then
        inherit git-r3
@@ -18,7 +18,3 @@ HOMEPAGE="https://github.com/BGO-OD/serialtalk"
 
 LICENSE="GPL-3+"
 SLOT="0"
-
-src_install() {
-       cmake-utils_src_install
-}