media-gfx/displaycal: 3.8.8.1 bump
authorBernard Cafarelli <voyageur@gentoo.org>
Thu, 14 Nov 2019 08:05:09 +0000 (09:05 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Thu, 14 Nov 2019 08:07:23 +0000 (09:07 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
media-gfx/displaycal/Manifest
media-gfx/displaycal/displaycal-3.8.8.1.ebuild [new file with mode: 0644]

index e57d1b6c9a977f8bc385c8f5d11a74000327981d..178f7b9d3e0bc761e2a8e3145fc07df36f5b1f43 100644 (file)
@@ -1,2 +1,3 @@
 DIST DisplayCAL-3.8.7.0.tar.gz 10619677 BLAKE2B 9b697d3548bd3a2a7a5f2bb38589bdd7e67ff964b613371a83ae11ec1a114874283d67a442f4336a1d50e86fe127ae755ea68865de112ea83520def404a6e715 SHA512 f47cda64648ef59c211aa54993ee423e80caf26f8942de88672e430bec7976d83f15c58fe9df8217217be48a1b36e8c3342fc3baf862077fe229da214fd38400
 DIST DisplayCAL-3.8.7.1.tar.gz 10621039 BLAKE2B be4e350a63efb615a363aea36e4e92bc837d0021088ab28f78e92ba0743af5e3930812c1154d32ff06d301461d44b50b483ea15e6954943204974cc264918057 SHA512 67f49b3ae85620f9e9c7e9d4162538f78ab160a590e6cb95f78203045e0d2d8d604abe3ab533030e9359d70292a8b7dd02174c99b3143fabd7ca27a3b07a5626
+DIST DisplayCAL-3.8.8.1.tar.gz 10625317 BLAKE2B 3e988221ee7d75d5a34b1cd69ab80737017c7e7a0fa16c3bc1587210b6b1108e623a3ccada3be8b99fae4c0a70f2cf45293222232f87f0ac13fedf2a1f22fcbd SHA512 e16cdc4590274f10fc122e18a5d94a1d326c43bc132e7af97c6f28c5a656f02203cfb7c73b92fa98d3ee2a8bbf560514615bc9b34c881d2758a5a6f2867092b3
diff --git a/media-gfx/displaycal/displaycal-3.8.8.1.ebuild b/media-gfx/displaycal/displaycal-3.8.8.1.ebuild
new file mode 100644 (file)
index 0000000..6d9baac
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils xdg
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
+HOMEPAGE="https://displaycal.net/"
+SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+       >=media-gfx/argyllcms-1.1.0
+       dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+       >=x11-libs/libX11-1.3.3
+       >=x11-apps/xrandr-1.3.2
+       >=x11-libs/libXxf86vm-1.1.0
+       >=x11-libs/libXinerama-1.1
+"
+RDEPEND="${DEPEND}
+       dev-python/faulthandler[${PYTHON_USEDEP}]
+       >=dev-python/numpy-1.2.1[${PYTHON_USEDEP}]
+"
+
+# Just in case someone renames the ebuild
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       # Do not generate udev/hotplug files
+       sed -e '/if os.path.isdir/s#/etc/udev/rules.d\|/etc/hotplug#\0-non-existant#' \
+               -i DisplayCAL/setup.py || die
+       # Prohibit setup from running xdg-* programs, resulting to sandbox violation
+       sed -e '/if which/s#xdg-icon-resource#\0-non-existant#' \
+               -e '/if which/s#xdg-desktop-menu#\0-non-existant#' \
+               -i DisplayCAL/postinstall.py || die
+
+       # Remove deprecated Encoding key from .desktop file
+       sed -e '/Encoding=UTF-8/d' -i misc/*.desktop  || die
+
+       # Remove x-world Media Type
+       sed -e 's/x\-world\/x\-vrml\;//g' \
+               -i misc/displaycal-vrml-to-x3d-converter.desktop || die
+
+       distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_icon_cache_update
+}