dev-python/ImageHash: version bump to 3.7.
authorMarius Brehler <marbre@linux.sungazer.de>
Thu, 19 Oct 2017 09:40:14 +0000 (11:40 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 20 Oct 2017 07:44:49 +0000 (09:44 +0200)
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Closes: https://github.com/gentoo/gentoo/pull/5983

dev-python/ImageHash/ImageHash-3.7.ebuild [new file with mode: 0644]
dev-python/ImageHash/Manifest

diff --git a/dev-python/ImageHash/ImageHash-3.7.ebuild b/dev-python/ImageHash/ImageHash-3.7.ebuild
new file mode 100644 (file)
index 0000000..56f5b80
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Image Hashing library"
+HOMEPAGE="https://github.com/JohannesBuchner/imagehash"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+       dev-python/numpy[${PYTHON_USEDEP}]
+       dev-python/pillow[${PYTHON_USEDEP}]
+       dev-python/pywavelets[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( ${RDEPEND} )"
+
+python_test() {
+       esetup.py test
+}
index 34184312a55fd5a383f4d5f09a5c1d93cbf478a4..ebaa8dfc6faf89e7416a1a1a53ed29dd64d4f021 100644 (file)
@@ -1 +1,2 @@
 DIST ImageHash-3.4.tar.gz 290881 SHA256 22d5afa8089cfd08807e8133c2f03c81272e959f1dc922a2dc924c612f419841 SHA512 a4ba260988d81135f073bfc9a1b1253a69e8736da61e09ac93f8403ca237bfe85c3f0b4791546af601d62a306dd3346ecccf8ebd00d5cd8f4c6ca717b9d89dba WHIRLPOOL 0f4d837197db6a2407c0901403cb8c0effffb167d2517be0a7264fbec108d6f70739c980c00a648fe94b471273d2c6d52bd4f4e371cf9392e7c1177467077a08
+DIST ImageHash-3.7.tar.gz 294629 SHA256 09346020334afc317f79fe162928418f4b2c7e7e053638033f60339d39788c50 SHA512 e0da65d9d2a42ffce5c8b95017fd79bd002f48a963b956836695118e89bbb2ff936629a743248b4189439de155a0ec5f54a34d7cf7b803ae581b45f7bc02b500 WHIRLPOOL e3bb554a885c95669e1a2e02ccb8985d491d55b9b6e4df63a174f6cda71516c6c3e39b544574a620504017f7b9aa6b9683da66a6dfb1faf6852e72faf67e8d04