Initial version.
authorManuel Rüger <mrueg@gentoo.org>
Thu, 7 May 2015 21:00:21 +0000 (21:00 +0000)
committerManuel Rüger <mrueg@gentoo.org>
Thu, 7 May 2015 21:00:21 +0000 (21:00 +0000)
Package-Manager: portage-2.2.18/cvs/Linux x86_64

x11-plugins/pidgin-indicator/Manifest
x11-plugins/pidgin-indicator/metadata.xml [new file with mode: 0644]
x11-plugins/pidgin-indicator/pidgin-indicator-0.9.ebuild [new file with mode: 0644]

index 66cdc502ad7c805a03553b2f2aaa5a6fda397908..f2ca3faa743cf5ae9670e074d87bc6838fa58cf2 100644 (file)
@@ -1,3 +1,4 @@
 DIST pidgin-indicator-0.9.tar.gz 28350 SHA256 bf7b3c8914a96ef7953adb503b37e0e238682f264a21355fb99e7bf148db6b5c SHA512 bf16a47d44bb184815437c6bc70021777fb8e438838eb916351c59e82879e9bdaebd430ffa77c7d36e6b66d923813bcfb7c17759c8310eb6f9e260def4189ece WHIRLPOOL 29f23d84a327a8f885ef4fa1e64f422bd4b278582601f0d58a564fede66685ed20192453c1018e6ce4b171e5d03b63e00b82014926c03668394805d238f0e475
-EBUILD pidgin-indicator-0.9.ebuild 625 SHA256 682d3a951bffb82837807ed3b8cbb552aad8f62f941eda6cf1c2298233660d8f SHA512 bf9c9c3ff6252afcd6e653af39f230d755dbc0e2fd1c0970848a7df00972dd1a5c88544879efa666bf4aab20ad2df8cacb110b3781e2a8cb537900eae4d3156a WHIRLPOOL 21de687df792243cc46be22f34522c599853269430c376e2e684090d0477d1ab01f6fff7abaace881384a7f4d677f0ef66eae55d7de58f10b0a70b674567ecf4
+EBUILD pidgin-indicator-0.9.ebuild 742 SHA256 8e98f4349e82e7e4d21cab4a1b155fedfb65135aeb4b99c7e5beb98a95a7fdef SHA512 83a3e134c6ca350d9219a435ffe29b8387afa82a5c2fc2f1ca1d47f5f5c3e8e0616adec9acb8ca76a9d6b72d7e6bd70a19b9bb605c78c0d845c637ed6586b6cb WHIRLPOOL f18b27dd51af372b37b2e4fd663075180f26c926bdf40d7b1821becebe1ed3d1596026bf40ecd520e6e7c992c1636a38c08f2081073f857b41ce7ee9ddfa6465
+MISC ChangeLog 379 SHA256 8275c67d2c54d85f487fb5f181bf1ef64d8fad73fb3dd33631b7f7cdb792028d SHA512 2c3869c2ef926b388af14b8a418e87e022eba32619bcf285a167db153ddfbfc33e8237b5a3615139c8d77d99c164f6c331b1d8d86a76b8cf5543c9a5196f2af6 WHIRLPOOL 21337475b9422ff1ad3f5b49832a11ba9b7a23170d905addc423296dc11d1b0879c31d1f0318d300aaf29711cd9d2f22c4cc0ed37d93dba3812c19b098589cb4
 MISC metadata.xml 231 SHA256 9c04e1ed256c8293b1120d9b56de16e3ee5ff6cdb3967d517d46c5974c23d67a SHA512 0aaf70d152f2b3a4b333fccde6f5c9fbb6cac1a9ecf3e2b2ddb57a1c260b3f0e7bdd215edad17f959b2a3324929bf446164341531783431c3435d1b956d09d83 WHIRLPOOL d631165d8a2dd82731e34fed2e3c09437b8c0d383da28c3e0a5f704196afc1810a7efee388e6b558493e82fa61cc799ab3b93eb1b7b17464dd380efdcba60d06
diff --git a/x11-plugins/pidgin-indicator/metadata.xml b/x11-plugins/pidgin-indicator/metadata.xml
new file mode 100644 (file)
index 0000000..bfcb697
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>mrueg@gentoo.org</email>
+               <name>Manuel Rüger</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-indicator/pidgin-indicator-0.9.ebuild b/x11-plugins/pidgin-indicator/pidgin-indicator-0.9.ebuild
new file mode 100644 (file)
index 0000000..93db53f
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-indicator/pidgin-indicator-0.9.ebuild,v 1.1 2015/05/07 21:00:17 mrueg Exp $
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="Indicator plugin for Pidgin"
+HOMEPAGE="https://github.com/philipl/pidgin-indicator"
+SRC_URI="https://github.com/philipl/pidgin-indicator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+       dev-libs/libappindicator:2
+       net-im/pidgin[gtk]
+       x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+src_prepare() {
+       eautoreconf
+}
+
+src_install() {
+       default
+       find "${D}" -name "*.la" -exec rm {} + || die
+}