Really fix bug #136299.
authorCarsten Lohrke <carlo@gentoo.org>
Wed, 14 Jun 2006 22:31:24 +0000 (22:31 +0000)
committerCarsten Lohrke <carlo@gentoo.org>
Wed, 14 Jun 2006 22:31:24 +0000 (22:31 +0000)
Package-Manager: portage-2.1

kde-base/kdeaddons/ChangeLog
kde-base/kdeaddons/kdeaddons-3.5.3.ebuild
kde-base/noatun-plugins/ChangeLog
kde-base/noatun-plugins/noatun-plugins-3.5.3.ebuild

index 71c3de4130ea45f9a1d049108ec5936a1aa9930f..56dfa91fe037758bc72f56f3850bb82e8bbad5a9 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for kde-base/kdeaddons
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/ChangeLog,v 1.174 2006/06/13 11:52:54 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/ChangeLog,v 1.175 2006/06/14 22:31:24 carlo Exp $
+
+  14 Jun 2006; Carsten Lohrke <carlo@gentoo.org> kdeaddons-3.5.3.ebuild:
+  Really fix bug #136299.
 
   13 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> kdeaddons-3.5.3.ebuild:
   Repoman really should have detected this major tree breakage. ALWAYS quote
index 7297ab5c74aac352d4ae76f1f2af7d3a3aa84a46..8613c4bff6d63562992e3a73d2cef02840722177 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.5.3.ebuild,v 1.3 2006/06/13 11:52:54 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.5.3.ebuild,v 1.4 2006/06/14 22:31:24 carlo Exp $
 
 inherit db-use kde-dist
 
@@ -23,7 +23,8 @@ src_compile() {
        local myconf="$(use_with sdl) $(use_with xmms)"
 
        if use berkdb; then
-               myconf="${myconf} --with-berkeley-db --with-db-lib=$(db_libname)
+               dblib="$(db_libname)"
+               myconf="${myconf} --with-berkeley-db --with-db-lib=${dblib/-/_cxx-}
                        --with-extra-includes=${ROOT}$(db_includedir)"
        else
                myconf="${myconf} --without-berkeley-db"
index 9333eac75696192b1c52552fbd92b2dc4cd6609a..ab91d5b320cd9d3b106d9426f46f34b0be869ce5 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for kde-base/noatun-plugins
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.46 2006/06/12 22:20:32 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.47 2006/06/14 22:29:12 carlo Exp $
+
+  14 Jun 2006; Carsten Lohrke <carlo@gentoo.org>
+  noatun-plugins-3.5.3.ebuild:
+  Really fix bug #136299.
 
   12 Jun 2006; Carsten Lohrke <carlo@gentoo.org>
   noatun-plugins-3.5.3.ebuild:
index e878148b12f6fa5d65c4db81cbb33a7868fed86d..06120b119666573ebf341af75b386a2d64bfd381 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.5.3.ebuild,v 1.2 2006/06/12 22:20:32 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.5.3.ebuild,v 1.3 2006/06/14 22:29:12 carlo Exp $
 KMNAME=kdeaddons
 MAXKDEVER=$PV
 KM_DEPRANGE="$PV $MAXKDEVER"
@@ -20,7 +20,8 @@ src_compile() {
        local myconf="$(use_with sdl)"
 
        if use berkdb; then
-               myconf="${myconf} --with-berkeley-db --with-db-lib=$(db_libname)
+               dblib="$(db_libname)"
+               myconf="${myconf} --with-berkeley-db --with-db-lib=${dblib/-/_cxx-}
                        --with-extra-includes=${ROOT}$(db_includedir)"
        else
                myconf="${myconf} --without-berkeley-db"