Version bump.
authorMarien Zwart <marienz@gentoo.org>
Wed, 7 Jun 2006 17:01:21 +0000 (17:01 +0000)
committerMarien Zwart <marienz@gentoo.org>
Wed, 7 Jun 2006 17:01:21 +0000 (17:01 +0000)
Package-Manager: portage-2.1_rc4-r2

dev-python/setuptools/files/digest-setuptools-0.6_beta2 [new file with mode: 0644]
dev-python/setuptools/setuptools-0.6_beta2.ebuild [new file with mode: 0644]

diff --git a/dev-python/setuptools/files/digest-setuptools-0.6_beta2 b/dev-python/setuptools/files/digest-setuptools-0.6_beta2
new file mode 100644 (file)
index 0000000..26001d2
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 1fb3a6936dab5b1780f4fa81ad06af9d setuptools-0.6b2.zip 248375
+RMD160 62995cb7e1577d4da390adb00e285522b87d2ff3 setuptools-0.6b2.zip 248375
+SHA256 0fdfd2765b4fee3bf7eeb0f9312743c8d81d575b6bd5e7c97c6e2694075a1f05 setuptools-0.6b2.zip 248375
diff --git a/dev-python/setuptools/setuptools-0.6_beta2.ebuild b/dev-python/setuptools/setuptools-0.6_beta2.ebuild
new file mode 100644 (file)
index 0000000..e64754e
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6_beta2.ebuild,v 1.1 2006/06/07 17:01:21 marienz Exp $
+
+inherit distutils
+
+MY_P=${P/_beta/b}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A collection of enhancements to the Python distutils including easy install"
+HOMEPAGE="http://peak.telecommunity.com/DevCenter/setuptools"
+SRC_URI="http://cheeseshop.python.org/packages/source/s/setuptools/${MY_P}.zip"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.4.2"
+DEPEND="${RDEPEND}
+       app-arch/unzip"
+
+DOCS="EasyInstall.txt api_tests.txt pkg_resources.txt setuptools.txt"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       # The files in the tarball have 666 permissions and get installed
+       # that way if we do not chmod them.
+       find -type d -print0 | xargs -0 chmod 755
+       find -type f -print0 | xargs -0 chmod 644
+}
+
+src_test() {
+       "${python}" setup.py test || die "tests failed"
+}