net-misc/youtube-dl: Old
authorJeroen Roovers <jer@gentoo.org>
Thu, 31 Jan 2019 14:34:48 +0000 (15:34 +0100)
committerJeroen Roovers <jer@gentoo.org>
Thu, 31 Jan 2019 14:36:06 +0000 (15:36 +0100)
Package-Manager: Portage-2.3.59, Repoman-2.3.12
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/youtube-dl/Manifest
net-misc/youtube-dl/youtube-dl-2019.01.24.ebuild [deleted file]

index b922e5252170755601043048a76c9f858b6151cb..1ad4f77c73b05efc373de11a933884637cc8c111 100644 (file)
@@ -1,4 +1,3 @@
 DIST youtube-dl-2019.01.17.tar.gz 3088912 BLAKE2B 6cd46442d78126b3428135fcb820eb02bb2d567fe41fbfefcd80fc68a9ece0faaf2aa4981e31c619c3be1f789a9539236b1a71e72490c4ee667953837b25f0e5 SHA512 b8e81c2b2ec284033a5a92f49a965375d681d92435bc0402bb891b443f94d1321716a15717fe4e3c1fbc54ec610445282c52c18c046e140dd53731560230bd3f
-DIST youtube-dl-2019.01.24.tar.gz 3099596 BLAKE2B e8833a0432e32e843ed8a3e971b9572bc0f4f8e90ea9c26fe6426ccc95231d21cf85601615634611129405115fe1d3fc192f423c0d700beab7fbccfcfe25dc68 SHA512 23d81769dc202c6598a8ece772f104ed7a048464b3d14305492e562aa77dc77ef32e56ae7a1084b144460e18dcfb2a9d7813ef88f7fdc34760f62f4de23e4602
 DIST youtube-dl-2019.01.27.tar.gz 3102349 BLAKE2B 4d078cacc220e7c0ec46a395c58fddcefbdc4c6abfb68ba36eec0aa8a4506896132ac14c0edf1cafb8d55473931d1ce7f80cf0b08f2217c72c16d8084ed7afaf SHA512 33c7ac784b57feaa7b28b1cc0916f722fd958d111e3caeff6edf30bfe7d4f96bd61ee666dfaf672c75f1da7abc7d54510f7c9b7d7fdc2479e0dfd4625f4c6a42
 DIST youtube-dl-2019.01.30.1.tar.gz 3105464 BLAKE2B f09cf3e86710f6d3ec6555e18299097800775a44ed336fa54fd5abb8ea753806dc6431894659e51fef43b90f974250dbcce9bb51eed50e1e43b75fe40dd21fbd SHA512 4d1fd2b9cf84dbbbf3a7a84ce9e7b2fe39d34fb29c337c71c4dba598bc3eac9d205399055dbcd7ec964398dafac90d488188c4fbc5083ee0abfd09269dce26b3
diff --git a/net-misc/youtube-dl/youtube-dl-2019.01.24.ebuild b/net-misc/youtube-dl/youtube-dl-2019.01.24.ebuild
deleted file mode 100644 (file)
index 6ef55f5..0000000
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
-
-DESCRIPTION="Download videos from YouTube.com (and more sites...)"
-HOMEPAGE="https://rg3.github.com/youtube-dl/"
-SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="+offensive test"
-
-RDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="
-       ${RDEPEND}
-       test? ( dev-python/nose[coverage(+)] )
-"
-
-S="${WORKDIR}/${PN}"
-
-python_prepare_all() {
-       if ! use offensive; then
-               sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
-                       youtube_dl/version.py || die
-               # these have single line import statements
-               local xxx=(
-                       alphaporno anysex behindkink camwithher chaturbate eporner
-                       eroprofile extremetube foxgay goshgay hellporno hentaistigma
-                       hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
-                       pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
-                       slutload spankbang spankwire sunporno thisav vporn watchindianporn
-                       xbef xnxx xtube xvideos xxxymovies youjizz youporn
-               )
-               # these have multi-line import statements
-               local mxxx=(
-                       drtuber fourtube motherless pornhub redtube tnaflix tube8 xhamster
-               )
-               # do single line imports
-               sed -i \
-                       -e $( printf '/%s/d;' ${xxx[@]} ) \
-                       youtube_dl/extractor/extractors.py \
-                       || die
-
-               # do multiple line imports
-               sed -i \
-                       -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
-                       youtube_dl/extractor/extractors.py \
-                       || die
-
-               sed -i \
-                       -e $( printf '/%s/d;' ${mxxx[@]} ) \
-                       youtube_dl/extractor/generic.py \
-                       || die
-
-               rm \
-                       $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
-                       $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
-                       test/test_age_restriction.py \
-                       || die
-       fi
-
-       eapply_user
-
-       distutils-r1_python_prepare_all
-}
-
-src_compile() {
-       distutils-r1_src_compile
-}
-
-python_test() {
-       emake test
-}
-
-python_install_all() {
-       dodoc README.txt
-       doman ${PN}.1
-
-       newbashcomp ${PN}.bash-completion ${PN}
-
-       insinto /usr/share/zsh/site-functions
-       newins ${PN}.zsh _${PN}
-
-       insinto /usr/share/fish/vendor_completions.d
-       doins ${PN}.fish
-
-       distutils-r1_python_install_all
-
-       rm -r "${ED}"/usr/etc || die
-       rm -r "${ED}"/usr/share/doc/youtube_dl || die
-}
-
-pkg_postinst() {
-       elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
-       elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
-       elog
-       elog "${PN} works fine on its own on most sites. However, if you want"
-       elog "to convert video/audio, you'll need avconf (media-video/libav) or"
-       elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
-       elog "videos can be retrieved in a higher quality format without sound."
-       elog "${PN} will detect whether avconv/ffmpeg is present and"
-       elog "automatically pick the best option."
-       elog
-       elog "Videos or video formats streamed via RTMP protocol can only be"
-       elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
-       elog "Downloading MMS and RTSP videos requires either mplayer"
-       elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
-       elog
-       elog "If you want ${PN} to embed thumbnails from the metadata into the"
-       elog "resulting MP4 files, consider installing media-video/atomicparsley"
-}