games-action/maelstrom: Depend on acct-group/gamestat.
authorUlrich Müller <ulm@gentoo.org>
Mon, 8 Jul 2019 08:33:36 +0000 (10:33 +0200)
committerJames Le Cuirot <chewi@gentoo.org>
Wed, 17 Jul 2019 20:03:34 +0000 (21:03 +0100)
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-action/maelstrom/maelstrom-3.0.6-r3.ebuild

index bd1110643dbec171e6dfed2994ea18b5084f9e6a..db33e84ab966588775402319b8fef5d50fe873fb 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit autotools eutils user
+inherit autotools eutils
 
 MY_P=Maelstrom-${PV}
 DESCRIPTION="An asteroids battle game"
@@ -14,8 +14,9 @@ SLOT="0"
 LICENSE="GPL-2"
 IUSE=""
 
-DEPEND="media-libs/libsdl[sound,joystick,video]
-               media-libs/sdl-net"
+DEPEND="acct-group/gamestat
+       media-libs/libsdl[sound,joystick,video]
+       media-libs/sdl-net"
 RDEPEND="${DEPEND}"
 
 S=${WORKDIR}/${MY_P}
@@ -28,10 +29,6 @@ PATCHES=(
        "${FILESDIR}"/${P}-gcc53.patch
 )
 
-pkg_setup(){
-       enewgroup gamestat 36
-}
-
 src_prepare() {
        default