dev-python/os-client-config: add version 1.6.1
authorAlex Brandt <alunduil@gentoo.org>
Sun, 9 Aug 2015 19:23:43 +0000 (14:23 -0500)
committerAlex Brandt <alunduil@gentoo.org>
Sun, 9 Aug 2015 19:23:43 +0000 (14:23 -0500)
Package-Manager: portage-2.2.20

dev-python/os-client-config/Manifest [new file with mode: 0644]
dev-python/os-client-config/files/test_get_all_clouds.patch [new file with mode: 0644]
dev-python/os-client-config/metadata.xml [new file with mode: 0644]
dev-python/os-client-config/os-client-config-1.6.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/os-client-config/Manifest b/dev-python/os-client-config/Manifest
new file mode 100644 (file)
index 0000000..ddc867b
--- /dev/null
@@ -0,0 +1 @@
+DIST os-client-config-1.6.1.tar.gz 28783 SHA256 24323a33fe4ec4ff0c71a91aa16d26f4c4320f0b0234c5ac22d08f99e2f5c24d SHA512 3f71b17d70f2e7a75e6530203f84a5d32d9bb8c517d1379033ad5fb1d864bcb58c2b026bd2f177fe415b6c03498518bb5abb23df710c66ffd828619aeaf2a4f4 WHIRLPOOL 326c912ae153ad0bcbc7988743be880cb4b7be17762fee8a7ae82946f3502ca9085d0f17726c7d5f7aec4a81968d134674dfc55de3a14d91773279c66db445cb
diff --git a/dev-python/os-client-config/files/test_get_all_clouds.patch b/dev-python/os-client-config/files/test_get_all_clouds.patch
new file mode 100644 (file)
index 0000000..b6c9e82
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/os_client_config/tests/test_config.py b/os_client_config/tests/test_config.py
+index 6bb65fc..743ef76 100644
+--- a/os_client_config/tests/test_config.py
++++ b/os_client_config/tests/test_config.py
+@@ -38,7 +38,7 @@ class TestConfig(base.TestCase):
+             cloud for cloud in base.USER_CONF['clouds'].keys()
+         ] + ['_test_cloud_regions']
+         configured_clouds = [cloud.name for cloud in clouds]
+-        self.assertItemsEqual(user_clouds, configured_clouds)
++        self.assertSetEqual(set(user_clouds), set(configured_clouds))
+     def test_get_one_cloud(self):
+         c = config.OpenStackConfig(config_files=[self.cloud_yaml],
diff --git a/dev-python/os-client-config/metadata.xml b/dev-python/os-client-config/metadata.xml
new file mode 100644 (file)
index 0000000..02be8c5
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>alunduil@gentoo.org</email>
+               <name>Alex Brandt</name>
+       </maintainer>
+       <longdescription lang="en">
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-python/os-client-config/os-client-config-1.6.1.ebuild b/dev-python/os-client-config/os-client-config-1.6.1.ebuild
new file mode 100644 (file)
index 0000000..ee0908a
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Client Configuation Library"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               dev-python/extras[${PYTHON_USEDEP}]
+               >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-1.5.1[${PYTHON_USEDEP}]
+               <dev-python/oslotest-1.6.0[${PYTHON_USEDEP}]
+               >=dev-python/python-keystoneclient-1.1.0[${PYTHON_USEDEP}]
+               >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+               >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
+               !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
+       )
+       doc? (
+               >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+               <dev-python/oslo-sphinx-2.6.0[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+       local PATCHES=(
+               "${FILESDIR}"/test_get_all_clouds.patch
+       )
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && esetup.py build_sphinx
+}
+
+python_test() {
+       distutils_install_for_testing
+
+       rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+       testr init || die "testr init failed under ${EPYTHON}"
+       testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/build/html/. )
+
+       distutils-r1_python_install_all
+}