app-crypt/rhash: Version bump to 1.3.8
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 3 Mar 2019 10:36:14 +0000 (10:36 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 3 Mar 2019 10:36:14 +0000 (10:36 +0000)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
app-crypt/rhash/Manifest
app-crypt/rhash/rhash-1.3.8.ebuild [new file with mode: 0644]

index f83ea66c4fd7148c422342a3e408c0d9d564db12..d06bfdcfc68899ad26a3cca461c9d0e70133bd70 100644 (file)
@@ -1,2 +1,3 @@
 DIST rhash-1.3.6-src.tar.gz 328097 BLAKE2B c74993d183f0f2e479f0bd5831a9f653b9bd17bbed4d1ba896f6e33db98b7141175cd3c688dc41dfd8ec4b98acb51255ae5b795435cbc9dfb5ab77573cb25543 SHA512 54f7f238ed1fdc01c29cc1338fa86be90b69beff0df8f20d24ce9cb3c48c7f4668b84a3fe0d4d8b04b54bc8145485d493435edf3219de3a637af0f9c007c85c6
 DIST rhash-1.3.7-src.tar.gz 362981 BLAKE2B bc248e0dcdf2337e46292f1bcdff0ce027705679ab937c8aa13139226bc09f3815ba23d8383f624dfba255c54378473f6b0b28a710611cdc83150055b8d649d0 SHA512 182f474b0f0a39f9e0adb7e34fcc5ddca6f00e75d7cf6b846da33af166257b2ed38be70aa71e6732c4e6cbdd156712790b8bc5340933b65f3ce57269835d1585
+DIST rhash-1.3.8-src.tar.gz 393544 BLAKE2B c326b3fa6dbc5ea2cce40105dc319456fdcc58140a05e8002bf1d92be921d8bbd27bf670370ba7cf2ff2001ff70ddbeb8efc9712869a7b215c5f51a5e493b5c9 SHA512 9dba4fa4dd49d323f2e440c5b93eac1ef62eb4046ec4ef611f0978c12c1739002f1ac1f1ec5e61bd359dc89e9ed612db71be91a795184ac5d5433280d27fa4c1
diff --git a/app-crypt/rhash/rhash-1.3.8.ebuild b/app-crypt/rhash/rhash-1.3.8.ebuild
new file mode 100644 (file)
index 0000000..e179038
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="Console utility and library for computing and verifying file hash sums"
+HOMEPAGE="http://rhash.anz.ru/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="debug nls libressl ssl static-libs"
+
+RDEPEND="
+       ssl? (
+               !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+               libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+)"
+
+DEPEND="
+       ${RDEPEND}
+"
+
+BDEPEND="
+       nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/RHash-${PV}"
+
+src_prepare() {
+       default
+       # fix Solaris detection, upstream:
+       # https://github.com/rhash/RHash/pull/81
+       sed -i -e 's/sunos)/solaris2.*)/' configure || die
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       set -- \
+               ./configure \
+               --target="${CHOST}" \
+               --cc="$(tc-getCC)" \
+               --ar="$(tc-getAR)" \
+               --extra-cflags="${CFLAGS}" \
+               --extra-ldflags="${LDFLAGS}" \
+               --prefix="${EPREFIX}"/usr \
+               --libdir="${EPREFIX}"/usr/$(get_libdir) \
+               --sysconfdir="${EPREFIX}"/etc \
+               --disable-openssl-runtime \
+               --disable-static \
+               --enable-lib-shared \
+               $(use_enable debug) \
+               $(use_enable nls gettext) \
+               $(use_enable ssl openssl) \
+               $(use_enable static-libs lib-static)
+
+       echo "${@}"
+       "${@}" || die "configure failed"
+}
+
+# We would add compile-gmo to the build targets but install-gmo always
+# recompiles unconditionally. :(
+
+multilib_src_install() {
+       # -j1 needed due to race condition.
+       emake DESTDIR="${D}" -j1 \
+                 install{,-lib-headers,-pkg-config} \
+                 $(use nls && echo install-gmo) \
+                 $(use kernel_Winnt || echo install-lib-so-link)
+}
+
+multilib_src_test() {
+       emake test
+}