net-analyzer/flent: Drop USE=qt4
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 24 Jan 2018 21:57:08 +0000 (22:57 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 24 Jan 2018 22:00:34 +0000 (23:00 +0100)
Bug: https://bugs.gentoo.org/634960
Package-Manager: Portage-2.3.20, Repoman-2.3.6

net-analyzer/flent/flent-1.0.1-r1.ebuild [new file with mode: 0644]

diff --git a/net-analyzer/flent/flent-1.0.1-r1.ebuild b/net-analyzer/flent/flent-1.0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..d90d41a
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="The FLExible Network Tester"
+HOMEPAGE="https://flent.org/"
+SRC_URI="https://github.com/tohojo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+qt5 +plots"
+
+RDEPEND="qt5? ( dev-python/PyQt5[${PYTHON_USEDEP}] )
+               plots? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+               net-analyzer/netperf[demo]
+               net-misc/iperf
+               net-analyzer/fping"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"