net-analyzer/graphite-web-1.1.3-r1: drop old (old django dep)
authorFabian Groffen <grobian@gentoo.org>
Wed, 12 Feb 2020 10:50:53 +0000 (11:50 +0100)
committerFabian Groffen <grobian@gentoo.org>
Wed, 12 Feb 2020 10:50:53 +0000 (11:50 +0100)
Closes: https://bugs.gentoo.org/709320
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
net-analyzer/graphite-web/Manifest
net-analyzer/graphite-web/graphite-web-1.1.3-r1.ebuild [deleted file]

index 4f5f75d3c2b3d28ea9f17317a2c0c1ab9c111199..b2a84682aab57b16866e6cb631eee1d9939d6ee7 100644 (file)
@@ -1,2 +1 @@
-DIST graphite-web-1.1.3.tar.gz 1171342 BLAKE2B f18c84d707f93d897553ec05d7b910a3dba97c6068498d1b216f178ea8a1f64baf59bb572b433a56f5e417a2873c018a38a19c3b8c765f667d7c3fbb38b9ed0a SHA512 3f9de216bd55e4e8de7391087e9b876a16e4f137fd60932a6d5855804c3d9868422645177776258e74486b97ec7a853b63a6d89b1de9b325bcb50ad694208436
 DIST graphite-web-1.1.5.tar.gz 1173809 BLAKE2B 94a1b4deab3159d3bde2d3c8b6f9664f39942cb1b815ce042b196be3c0e769ee1acac4b619135e9471360849308b90e02e1df4f7d6b7d0ef31e46d38ee2425e5 SHA512 b2097609ca77a40e6e7d83a3141335e2208d69e7f4edbac8ce3505ed9dd654589836a3b3498bfb7f7585332bceeb8e367f0c10f3cf6afdb5ad6b96377338a7bb
diff --git a/net-analyzer/graphite-web/graphite-web-1.1.3-r1.ebuild b/net-analyzer/graphite-web/graphite-web-1.1.3-r1.ebuild
deleted file mode 100644 (file)
index cd145d2..0000000
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 prefix
-
-DESCRIPTION="Enterprise scalable realtime graphing"
-HOMEPAGE="https://graphiteapp.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+carbon ldap mysql memcached postgres +sqlite"
-
-DEPEND=""
-RDEPEND="
-       carbon? ( dev-python/carbon[${PYTHON_USEDEP}] )
-       ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
-       memcached? ( dev-python/python-memcached[${PYTHON_USEDEP}] )
-       mysql? (
-               || (
-                       dev-python/mysql-python[${PYTHON_USEDEP}]
-                       dev-python/mysqlclient[${PYTHON_USEDEP}]
-               )
-       )
-       postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
-       >=dev-python/django-1.8[sqlite?,${PYTHON_USEDEP}]
-       <dev-python/django-1.11.99[sqlite?,${PYTHON_USEDEP}]
-       >=dev-python/django-tagging-0.4.3[${PYTHON_USEDEP}]
-       dev-python/cairocffi[${PYTHON_USEDEP}]
-       dev-python/pyparsing[${PYTHON_USEDEP}]
-       dev-python/pytz[${PYTHON_USEDEP}]
-       dev-python/scandir[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       dev-python/urllib3[${PYTHON_USEDEP}]
-       media-libs/fontconfig
-"
-
-PATCHES=(
-       # Do not install the configuration and data files. We install them
-       # somewhere sensible by hand.
-       "${FILESDIR}"/${PN}-1.1.3-fhs-paths.patch
-)
-
-python_prepare_all() {
-       # Use a less common name
-       mv bin/build-index bin/${PN}-build-index || die
-       # use FHS-style paths
-       export GRAPHITE_NO_PREFIX=yes
-       distutils-r1_python_prepare_all
-       eprefixify \
-               conf/graphite.wsgi.example \
-               webapp/graphite/local_settings.py.example
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       keepdir /var/{lib,log}/${PN}
-       docinto examples
-       docompress -x "/usr/share/doc/${PF}/examples"
-       dodoc \
-               examples/example-graphite-vhost.conf \
-               conf/dashboard.conf.example \
-               conf/graphite.wsgi.example
-}
-
-python_install() {
-       distutils-r1_python_install \
-               --install-data="${EPREFIX}"/usr/share/${PN}
-
-       insinto /etc/${PN}
-       newins webapp/graphite/local_settings.py.example local_settings.py
-       pushd "${D}/$(python_get_sitedir)"/graphite > /dev/null || die
-       ln -s ../../../../../etc/${PN}/local_settings.py local_settings.py || die
-       popd > /dev/null || die
-}
-
-pkg_config() {
-       "${EROOT}"/usr/bin/django-admin.py migrate \
-               --settings=graphite.settings --run-syncdb
-       "${EROOT}"/usr/bin/${PN}-build-index
-}
-
-pkg_postinst() {
-       # Only display this for new installs
-       if [[ -z ${REPLACING_VERSIONS} ]]; then
-               elog "You need to configure ${PN} to run with a WSGI server of your choice."
-               elog "For example using Apache, you can use www-apache/mod_wsgi,"
-               elog "            using Nginx, you can use www-servers/uwsgi."
-               elog "Don't forget to edit local_settings.py in ${EPREFIX}/etc/${PN}"
-               elog "See https://graphite.readthedocs.org/en/latest/config-local-settings.html"
-               elog "Run emerge --config =${PN}-${PVR} if this is a fresh install."
-               elog ""
-               elog "If you want to update the search index regularily, you should consider running"
-               elog "the '${PN}-build-index' script in a crontab."
-       fi
-}