dev-vcs/git-cola: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Mon, 14 Sep 2015 12:49:42 +0000 (14:49 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 14 Sep 2015 12:49:48 +0000 (14:49 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-vcs/git-cola/Manifest
dev-vcs/git-cola/git-cola-2.3.ebuild [new file with mode: 0644]

index 25d590c0a2d59dd13cbddc69af9a1ec769953675..a0fa8dc3742e401d509f2e249d43df078b0858fa 100644 (file)
@@ -1,2 +1,3 @@
 DIST git-cola-2.1.2.tar.gz 960514 SHA256 f0465f74858fc78b1b30e06856cdd6b5fa5f0cb9587b5c7e9b489f4d0e4d8f8d SHA512 79eae7937db148cde22b3d5dc1564180c3919965c35c11853270525be4eb19c7f223ddc215ba8122ed8bcb70e0e6ec57948f1e02aeeae1a9c3e7c98efef1e42d WHIRLPOOL 8797f0f0d02eaea1c7e1ef5544fc7e5e2bf6ca738cff721ce56db194de8cd94a3e825bf557f478237d75c5cf782ed43cdafc7a7afdaf1417fa4f3d8b65bcb756
 DIST git-cola-2.2.1.tar.gz 996484 SHA256 df0a3e1d3c49629926f2e30f55d635eca3c8da12e96232196b307613fa4b3aec SHA512 a91fe706ea150d9bd9a05a9d494c63d373cae0154deca8e40e30fc20e70be32d4fd1f021a971c067d46ab24f472965a12c115eeb4bd94e4f62c21e546d89c109 WHIRLPOOL ac68a558775bc5fdf3a168416132dedbeffe554f6f60f50b7e33f0d17d67aa829318b7a0df2607b47e41b8823d60e206e0544e03382eae7651b9ca1c3b9dfc09
+DIST git-cola-2.3.tar.gz 1005858 SHA256 3319810c16f6864deb5f94f533c7cfd17f30961595454da7c3c75879f56511b3 SHA512 2be0e971cd23aa0a1f8ec92ffd05f64cdd0ee34fb1e3c9bd3a98df0556968e9613d6494002e973db8de8ab389c48205ab1db42823d46e523c24a029cf25e3023 WHIRLPOOL 177996e40cc83dd2d2fe9db1ac97ba318d9d311779415e8e4327f3824a7c19f36f592ed1d6118e5a2d46a594a8dd681d0a2e2e54f2846c3636d9f4f3d8f196f5
diff --git a/dev-vcs/git-cola/git-cola-2.3.ebuild b/dev-vcs/git-cola/git-cola-2.3.ebuild
new file mode 100644 (file)
index 0000000..e65d904
--- /dev/null
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1 readme.gentoo virtualx
+
+DESCRIPTION="The highly caffeinated git GUI"
+HOMEPAGE="https://git-cola.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+       dev-python/pyinotify[${PYTHON_USEDEP}]
+       dev-python/send2trash[${PYTHON_USEDEP}]
+       dev-python/PyQt4[${PYTHON_USEDEP}]
+       dev-vcs/git"
+DEPEND="${RDEPEND}
+       sys-devel/gettext
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               python_targets_python2_7? ( dev-python/sphinxtogithub[$(python_gen_usedep 'python2*')] )
+               )
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.2.1-disable-live-tests.patch
+)
+
+python_prepare_all() {
+       rm share/git-cola/bin/*askpass* || die
+
+       # remove broken tests
+       rm test/i18n_test.py || die
+
+       # don't install docs into wrong location
+       sed -i -e '/doc/d' setup.py || die
+
+       # fix doc directory reference
+       sed -i \
+               -e "s/'doc', 'git-cola'/'doc', '${PF}'/" \
+               cola/resources.py || die
+
+       # fix ssh-askpass directory reference
+       sed -i -e 's/resources\.share/resources\.prefix/' cola/app.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       cd share/doc/${PN}/ || die
+       if use doc; then
+               emake all
+       else
+               sed \
+                       -e '/^install:/s:install-html::g' \
+                       -e '/^install:/s:install-man::g' \
+                       -i Makefile || die
+       fi
+}
+
+python_test() {
+       PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" \
+       VIRTUALX_COMMAND="nosetests --verbose --with-id --with-doctest \
+               --exclude=sphinxtogithub" \
+       virtualmake
+}
+
+src_install() {
+       distutils-r1_src_install
+}
+
+python_install_all() {
+       cd share/doc/${PN}/ || die
+       emake \
+               DESTDIR="${D}" \
+               docdir="${EPREFIX}/usr/share/doc/${PF}" \
+               prefix="${EPREFIX}/usr" \
+               install
+
+       python_fix_shebang "${ED}/usr/share/git-cola/bin/git-xbase"
+       python_optimize "${ED}/usr/share/git-cola/lib/cola"
+
+       use doc || HTML_DOCS=( "${FILESDIR}"/index.html )
+
+       distutils-r1_python_install_all
+       readme.gentoo_create_doc
+}