dev-db/mycli: New package, ebuilds by me
authorBrian Evans <grknight@gentoo.org>
Tue, 15 Sep 2015 17:26:44 +0000 (13:26 -0400)
committerBrian Evans <grknight@gentoo.org>
Tue, 15 Sep 2015 17:26:44 +0000 (13:26 -0400)
Package-Manager: portage-2.2.20.1

dev-db/mycli/Manifest [new file with mode: 0644]
dev-db/mycli/metadata.xml [new file with mode: 0644]
dev-db/mycli/mycli-1.4.0.ebuild [new file with mode: 0644]
dev-db/mycli/mycli-9999.ebuild [new file with mode: 0644]

diff --git a/dev-db/mycli/Manifest b/dev-db/mycli/Manifest
new file mode 100644 (file)
index 0000000..9f1ad0d
--- /dev/null
@@ -0,0 +1 @@
+DIST mycli-1.4.0.tar.gz 250369 SHA256 300b26d21fc75fecdff04133dac7a22550f8f537b8571985ec02e8e346b00fb5 SHA512 06176a62646be4bac2b90f72bc728afc8920e9ff1b0c04749a5601ee63d35ba2159f48e61e23df6ca3bc5477486f3e3917b3a8de8b7034594f4ed2c544f2969f WHIRLPOOL 6ade59f9c8d7927710df0e2cd4e77cd450468b7558ce9ce763cc54e172a75fd2a84017fe3cc0e9d20a5dbd05585d80d135063b96a7692cd23c76a90806ff1aac
diff --git a/dev-db/mycli/metadata.xml b/dev-db/mycli/metadata.xml
new file mode 100644 (file)
index 0000000..9516a92
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<use>
+</use>
+       <maintainer>
+               <email>grknight@gentoo.org</email>
+               <name>Brian Evans</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-db/mycli/mycli-1.4.0.ebuild b/dev-db/mycli/mycli-1.4.0.ebuild
new file mode 100644 (file)
index 0000000..147548d
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="CLI for MySQL Database with auto-completion and syntax highlighting"
+
+HOMEPAGE="http://mycli.net"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+       >=dev-python/click-4.1[${PYTHON_USEDEP}]
+       >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+       >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+       =dev-python/prompt_toolkit-0.46[${PYTHON_USEDEP}]
+       >=dev-python/pymysql-0.6.6[${PYTHON_USEDEP}]
+       >=dev-python/python-sqlparse-0.1.16[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+       rm mycli/packages/counter.py || die "Could not remove python 2.6 counter.py"
+       distutils-r1_src_prepare
+}
diff --git a/dev-db/mycli/mycli-9999.ebuild b/dev-db/mycli/mycli-9999.ebuild
new file mode 100644 (file)
index 0000000..a21b495
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+EGIT_REPO_URI="https://github.com/dbcli/mycli.git"
+inherit distutils-r1 git-r3
+
+DESCRIPTION="CLI for MySQL Database with auto-completion and syntax highlighting"
+
+HOMEPAGE="http://mycli.net"
+SRC_URI=""
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+       >=dev-python/click-4.1[${PYTHON_USEDEP}]
+       >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+       >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+       =dev-python/prompt_toolkit-0.46[${PYTHON_USEDEP}]
+       >=dev-python/pymysql-0.6.6[${PYTHON_USEDEP}]
+       >=dev-python/python-sqlparse-0.1.16[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+       rm mycli/packages/counter.py || die "Could not remove python 2.6 counter.py"
+       distutils-r1_src_prepare
+}