Version bump to 0.3.2 version. This is what was going to be used for 2006.0-r1,...
authorChris Gianelloni <wolf31o2@gentoo.org>
Thu, 8 Jun 2006 20:55:45 +0000 (20:55 +0000)
committerChris Gianelloni <wolf31o2@gentoo.org>
Thu, 8 Jun 2006 20:55:45 +0000 (20:55 +0000)
Package-Manager: portage-2.1_rc4-r3

sys-apps/gli/ChangeLog
sys-apps/gli/files/digest-gli-0.3.2 [new file with mode: 0644]
sys-apps/gli/gli-0.3.1.ebuild
sys-apps/gli/gli-0.3.2.ebuild [new file with mode: 0644]

index ce7f561522229fc5f78967831568bd5e25493ff9..583e3970a227b9839f4075bb26b9722e110d4875 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for sys-apps/gli
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/ChangeLog,v 1.5 2006/05/03 14:45:55 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/ChangeLog,v 1.6 2006/06/08 20:55:45 wolf31o2 Exp $
+
+*gli-0.3.2 (08 Jun 2006)
+
+  08 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org> gli-0.3.1.ebuild,
+  +gli-0.3.2.ebuild:
+  Version bump to 0.3.2 version. This is what was going to be used for
+  2006.0-r1, which was cancelled, but it will be used for testing for 2006.1
+  until a newer snapshot is made for the release.
 
   03 May 2006; Chris Gianelloni <wolf31o2@gentoo.org> gli-0.3.1.ebuild:
   Added python eclass to pre-compile the python modules, and added a warning
diff --git a/sys-apps/gli/files/digest-gli-0.3.2 b/sys-apps/gli/files/digest-gli-0.3.2
new file mode 100644 (file)
index 0000000..d581df6
--- /dev/null
@@ -0,0 +1 @@
+MD5 d5ed79473708138cf7d453966c020ecb installer-0.3.2.tar.bz2 792702
index 95978e7e0ed00287122d29b628ee6f1029f63f58..10f08c318f358a827d6e9a42d0432faa5fe302db 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/gli-0.3.1.ebuild,v 1.2 2006/05/03 14:45:55 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/gli-0.3.1.ebuild,v 1.3 2006/06/08 20:55:45 wolf31o2 Exp $
 
 inherit python eutils
 
@@ -49,11 +49,12 @@ src_install() {
 }
 
 pkg_postinst() {
-       python_mod_optimize
+       python_mod_optimize ${dir}
        einfo "The Gentoo Linux Installer is currently only usable for two situations."
        einfo "The first is for building an install profile."
        einfo "The second is for installing using official Gentoo release media."
        echo
        ewarn "If you are trying to use the installer for anything else, please"
        ewarn "file patches with any bugs."
+       echo
 }
diff --git a/sys-apps/gli/gli-0.3.2.ebuild b/sys-apps/gli/gli-0.3.2.ebuild
new file mode 100644 (file)
index 0000000..d0c3fe5
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gli/gli-0.3.2.ebuild,v 1.1 2006/06/08 20:55:45 wolf31o2 Exp $
+
+inherit python eutils
+
+DESCRIPTION="Gentoo Linux Installer"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/installer/"
+#SRC_URI="http://dev.gentoo.org/~agaffney/gli/snapshots/installer-${PV}.tar.bz2"
+SRC_URI="http://dev.gentoo.org/~agaffney/${PN}/releases/installer-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk"
+
+RDEPEND=">=dev-python/pyparted-1.6.6
+       gtk? ( >=dev-python/pygtk-2.4.0 )
+       =dev-python/pythondialog-2.7*
+       sys-fs/e2fsprogs
+       sys-fs/ntfsprogs
+       sys-fs/reiserfsprogs
+       sys-fs/dosfstools
+       !amd64? (
+               sys-fs/hfsutils
+               sys-fs/hfsplusutils )"
+
+S=${WORKDIR}/installer/src
+
+dir=/opt/installer
+Ddir=${D}/${dir}
+
+src_install() {
+       dodir ${dir}
+       exeinto ${dir}/bin
+       use !gtk && rm -rf ${S}/fe/gtk
+       cp -a ${S}/* ${Ddir}
+       doexe ${FILESDIR}/installer-dialog ${FILESDIR}/installer \
+               || die "copying dialog/installer scripts"
+       chown -R root:0 ${Ddir}
+       dodir /usr/bin
+       if use gtk; then
+               doexe ${FILESDIR}/installer-gtk || die "copying gtk script"
+               make_wrapper installer-gtk ./installer-gtk ${dir}/bin
+       fi
+       make_wrapper installer-dialog ./installer-dialog ${dir}/bin
+       make_wrapper installer ./installer ${dir}/bin
+       doicon ${FILESDIR}/gli.png ${FILESDIR}/gli-dialog.png
+       domenu ${FILESDIR}/installer-gtk.desktop \
+               ${FILESDIR}/installer-dialog.desktop \
+               ${FILESDIR}/installer-faq.desktop
+}
+
+pkg_postinst() {
+       python_mod_optimize ${dir}
+       einfo "The Gentoo Linux Installer is currently only usable for two situations."
+       einfo "The first is for building an install profile."
+       einfo "The second is for installing using official Gentoo release media."
+       echo
+       ewarn "If you are trying to use the installer for anything else, please"
+       ewarn "file patches with any bugs."
+       echo
+}