app-emacs/expand-region: Inline autoloads.
authorUlrich Müller <ulm@gentoo.org>
Thu, 17 Oct 2019 11:05:45 +0000 (13:05 +0200)
committerUlrich Müller <ulm@gentoo.org>
Thu, 17 Oct 2019 13:18:49 +0000 (15:18 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/expand-region/expand-region-0.11.0-r1.ebuild [moved from app-emacs/expand-region/expand-region-0.11.0.ebuild with 52% similarity]
app-emacs/expand-region/files/50expand-region-gentoo.el

similarity index 52%
rename from app-emacs/expand-region/expand-region-0.11.0.ebuild
rename to app-emacs/expand-region/expand-region-0.11.0-r1.ebuild
index b151534d2ef7b8e05b0a0f7639fe24efa75128b7..520e27025fafd6dbe2e5b0a76e64c0aada598038 100644 (file)
@@ -1,23 +1,18 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit elisp
 
 DESCRIPTION="Emacs extension to increase selected region by semantic units"
 HOMEPAGE="https://github.com/magnars/expand-region.el"
-SRC_URI="https://github.com/magnars/expand-region.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/magnars/${PN}.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="GPL-3+"
 SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
 
-S="${WORKDIR}/expand-region.el-${PV}"
+S="${WORKDIR}/${PN}.el-${PV}"
 SITEFILE="50${PN}-gentoo.el"
 DOCS="README.md"
-
-src_compile() {
-       elisp-compile *.el
-       elisp-make-autoload-file
-}
index bd5b4054078091318efc2ff80df6f9894aa56873..4b065061de9e51a505b4f5608e63b8a3753cce41 100644 (file)
@@ -1,2 +1,3 @@
 (add-to-list 'load-path "@SITELISP@")
-(load "expand-region-autoloads" nil t)
+(autoload 'er/expand-region "expand-region"
+  "Increase selected region by semantic units." t)