dev-libs/liblinear: Revert "Add IUSE=blas."
authorJeroen Roovers <jer@gentoo.org>
Sun, 11 Aug 2019 09:53:41 +0000 (11:53 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sun, 11 Aug 2019 10:06:09 +0000 (12:06 +0200)
In commit 22acd3654a599abcfe5457c157b6e2937a0242ec ("Add IUSE=blas.") I
tried to add support for linking against a BLAS implementation as
suggested in liblinear's documentation.

As so far liblinear does not support any helpers for linking against it
as well as a BLAS library in an automated way, enabling USE=blas can
result in linking failures in packages that are unaware of the BLAS
linkage. Until a pkg-config file or other reliable source for library
linkage is provided with liblinear, usage of an external BLAS library
cannot be supported.

Package-Manager: Portage-2.3.71, Repoman-2.3.17
Fixes: https://bugs.gentoo.org/691926
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
dev-libs/liblinear/liblinear-210-r1.ebuild
dev-libs/liblinear/liblinear-221.ebuild
dev-libs/liblinear/liblinear-230.ebuild

index ca03976be48ab908689bc29cf9646251aa98ac8e..cb9a44912d2a3b10d80f0c4bf0342a011c5b23ea 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -12,15 +12,6 @@ SRC_URI="https://github.com/cjlin1/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0/3"
 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="blas"
-
-RDEPEND="
-       blas? ( virtual/blas )
-"
-DEPEND="
-       ${RDEPEND}
-       blas? ( virtual/pkgconfig )
-"
 
 src_prepare() {
        sed -i \
@@ -34,9 +25,6 @@ src_prepare() {
                -e '/^CFLAGS/d;/^CXXFLAGS/d' \
                -e 's|$${SHARED_LIB_FLAG}|& $(LDFLAGS)|g' \
                Makefile || die
-       if use blas; then
-               sed -i -e 's:blas/blas.a::g' Makefile || die
-       fi
 }
 
 src_compile() {
@@ -47,7 +35,6 @@ src_compile() {
                CXXFLAGS="${CXXFLAGS} -fPIC" \
                AR="$(tc-getAR) rcv" \
                RANLIB="$(tc-getRANLIB)" \
-               LIBS="$(usex blas "$( $(tc-getPKG_CONFIG) --libs blas )" blas/blas.a)" \
                lib all
 }
 
index 1aaede97f49f7e1ebdd85d0330b726c01b5808b2..18f397fed81565500883b4909bb71365a315b2d7 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="7"
@@ -11,15 +11,6 @@ SRC_URI="https://github.com/cjlin1/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0/3"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
-IUSE="blas"
-
-RDEPEND="
-       blas? ( virtual/blas )
-"
-DEPEND="
-       ${RDEPEND}
-       blas? ( virtual/pkgconfig )
-"
 
 src_prepare() {
        default
@@ -35,9 +26,6 @@ src_prepare() {
                -e '/^CFLAGS/d;/^CXXFLAGS/d' \
                -e 's|$${SHARED_LIB_FLAG}|& $(LDFLAGS)|g' \
                Makefile || die
-       if use blas; then
-               sed -i -e 's:blas/blas.a::g' Makefile || die
-       fi
 }
 
 src_compile() {
@@ -48,7 +36,6 @@ src_compile() {
                CXXFLAGS="${CXXFLAGS} -fPIC" \
                AR="$(tc-getAR) rcv" \
                RANLIB="$(tc-getRANLIB)" \
-               LIBS="$(usex blas "$( $(tc-getPKG_CONFIG) --libs blas )" blas/blas.a)" \
                lib all
 }
 
index 00881437e2d50e367e5b519fd4e3bc83e0e65a62..18f397fed81565500883b4909bb71365a315b2d7 100644 (file)
@@ -11,15 +11,6 @@ SRC_URI="https://github.com/cjlin1/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0/3"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
-IUSE="blas"
-
-RDEPEND="
-       blas? ( virtual/blas )
-"
-DEPEND="
-       ${RDEPEND}
-       blas? ( virtual/pkgconfig )
-"
 
 src_prepare() {
        default
@@ -35,9 +26,6 @@ src_prepare() {
                -e '/^CFLAGS/d;/^CXXFLAGS/d' \
                -e 's|$${SHARED_LIB_FLAG}|& $(LDFLAGS)|g' \
                Makefile || die
-       if use blas; then
-               sed -i -e 's:blas/blas.a::g' Makefile || die
-       fi
 }
 
 src_compile() {
@@ -48,7 +36,6 @@ src_compile() {
                CXXFLAGS="${CXXFLAGS} -fPIC" \
                AR="$(tc-getAR) rcv" \
                RANLIB="$(tc-getRANLIB)" \
-               LIBS="$(usex blas "$( $(tc-getPKG_CONFIG) --libs blas )" blas/blas.a)" \
                lib all
 }