Version bump (bug #156805), fixes bugs #154505, #148399, #158050
authorTiziano Müller <dev-zero@gentoo.org>
Fri, 29 Dec 2006 12:51:32 +0000 (12:51 +0000)
committerTiziano Müller <dev-zero@gentoo.org>
Fri, 29 Dec 2006 12:51:32 +0000 (12:51 +0000)
Package-Manager: portage-2.1.2_rc4-r1

dev-python/wxpython/ChangeLog
dev-python/wxpython/files/digest-wxpython-2.6.3.3 [new file with mode: 0644]
dev-python/wxpython/wxpython-2.6.3.3.ebuild [new file with mode: 0644]

index b1336b2c35646402899fee5d617438d79957af3f..ea4d6a39fd97a89c548e7c31fe403ca28b63891b 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/wxpython
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.43 2006/10/15 06:00:25 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.44 2006/12/29 12:51:32 dev-zero Exp $
+
+*wxpython-2.6.3.3 (29 Dec 2006)
+
+  29 Dec 2006; Tiziano Müller <dev-zero@gentoo.org>
+  -wxpython-2.6.3.2.ebuild, +wxpython-2.6.3.3.ebuild:
+  Version bump (bug #156805), fixes bugs #154505, #148399, #158050
 
   15 Oct 2006; Mart Raudsepp <leio@gentoo.org> -wxpython-2.4.2.4.ebuild,
   -wxpython-2.6.0.0-r1.ebuild:
diff --git a/dev-python/wxpython/files/digest-wxpython-2.6.3.3 b/dev-python/wxpython/files/digest-wxpython-2.6.3.3
new file mode 100644 (file)
index 0000000..642b5d8
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 66b9c5f8e20a9505c39dab1a1234daa9 wxPython-src-2.6.3.3.tar.bz2 18963104
+RMD160 7feacff6808574143590a0a421ee60f3692eb783 wxPython-src-2.6.3.3.tar.bz2 18963104
+SHA256 fd2c4338beac644ebc509766f1e33892fc34d19280c5cbd66746625f96a55acb wxPython-src-2.6.3.3.tar.bz2 18963104
diff --git a/dev-python/wxpython/wxpython-2.6.3.3.ebuild b/dev-python/wxpython/wxpython-2.6.3.3.ebuild
new file mode 100644 (file)
index 0000000..888210b
--- /dev/null
@@ -0,0 +1,113 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.3.3.ebuild,v 1.1 2006/12/29 12:51:32 dev-zero Exp $
+
+inherit python wxwidgets eutils multilib
+
+MY_P="${P/wxpython-/wxPython-src-}"
+DESCRIPTION="A blending of the wxWindows C++ class library with Python"
+HOMEPAGE="http://www.wxpython.org/"
+SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2"
+
+LICENSE="wxWinLL-3"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="unicode opengl"
+
+RDEPEND=">=dev-lang/python-2.1
+       >=x11-libs/wxGTK-${PV}
+       >=x11-libs/gtk+-2.0
+       >=x11-libs/pango-1.2
+       >=dev-libs/glib-2.0
+       media-libs/libpng
+       media-libs/jpeg
+       media-libs/tiff
+       >=sys-libs/zlib-1.1.4
+       opengl? ( >=dev-python/pyopengl-2.0.0.44 )
+       !<dev-python/wxpython-2.4.2.4-r1"
+
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}/wxPython/"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}" || die "failed to cd to ${S}"
+       sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
+       epatch "${FILESDIR}/scripts-multiver-2.6.1.0.diff"
+}
+
+src_compile() {
+       local mypyconf
+       export WX_GTK_VER="2.6"
+       if use unicode; then
+               need-wxwidgets unicode || die "Please re-emerge wxGTK with unicode " \
+               "in USE"
+       else
+               need-wxwidgets gtk2
+       fi
+
+       mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
+       use opengl \
+               &&      mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+               || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
+
+       mypyconf="${mypyconf} WXPORT=gtk2"
+
+       use unicode && mypyconf="${mypyconf} UNICODE=1"
+
+       python setup.py ${mypyconf} build || die "build failed"
+}
+
+src_install() {
+       python_version
+       local mypyconf
+       local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+       dodir ${site_pkgs}
+
+       mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
+       use opengl \
+               && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+               || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
+
+       mypyconf="${mypyconf} WXPORT=gtk2"
+
+       use unicode && mypyconf="${mypyconf} UNICODE=1"
+
+       python setup.py ${mypyconf} install --prefix=/usr --root="${D}" || die
+
+       if [ -e "${site_pkgs}/wx.pth" ] && [ "`grep -o 2.4 ${site_pkgs}/wx.pth`" = "2.4" ]; then
+               rm "${D}"/${site_pkgs}/wx.pth
+               einfo "Keeping 2.4 as system default wxPython"
+       else
+               if use unicode; then
+                       wx_name=wx-${PV:0:3}-gtk2-unicode
+               else
+                       wx_name=wx-${PV:0:3}-gtk2-ansi
+               fi
+
+               einfo "Setting ${wx_name} as system default wxPython"
+               echo ${wx_name} > ${D}/${site_pkgs}/wx.pth || \
+                       die "Couldn't create wx.pth"
+
+       fi
+
+       cp "${FILESDIR}"/wxpy-config.py "${D}"/${site_pkgs}/
+
+       #Add ${PV} suffix to all /usr/bin/* programs to avoid clobbering SLOT'd
+       for filename in "${D}"/usr/bin/* ; do
+               mv ${filename} ${filename}-2.6
+       done
+}
+
+pkg_postinst() {
+
+       einfo "Gentoo now uses the Multi-version method for SLOT'ing"
+       einfo "Developers see this site for instructions on using 2.4 or 2.6"
+       einfo "with your apps:"
+       einfo "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
+       einfo "2.4 is still the default wxpython for now, but 2.6 apps should"
+       einfo "see the above website for selecting the 2.6 lib"
+}
+