media-libs/smpeg2: fix build failure against gcc-6, bug #594912
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 27 Feb 2017 21:55:27 +0000 (21:55 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 27 Feb 2017 21:55:36 +0000 (21:55 +0000)
Reported-by: Toralf Förster
Bug: https://bugs.gentoo.org/594912

Package-Manager: Portage-2.3.3, Repoman-2.3.1

media-libs/smpeg2/files/smpeg2-2.0.0-gcc6.patch [new file with mode: 0644]
media-libs/smpeg2/smpeg2-2.0.0-r3.ebuild

diff --git a/media-libs/smpeg2/files/smpeg2-2.0.0-gcc6.patch b/media-libs/smpeg2/files/smpeg2-2.0.0-gcc6.patch
new file mode 100644 (file)
index 0000000..4094c61
--- /dev/null
@@ -0,0 +1,23 @@
+gcc-6 is more strict WRT narrowing:
+error: narrowing conversion of ‘-1’ from ‘int’ to ‘unsigned int’ inside { } [-Wnarrowing]
+
+https://bugs.gentoo.org/594912
+diff --git a/audio/hufftable.cpp b/audio/hufftable.cpp
+index 6bc8e86..5414ae3 100644
+--- a/audio/hufftable.cpp
++++ b/audio/hufftable.cpp
+@@ -552,3 +552,3 @@ const HUFFMANCODETABLE MPEGaudio::ht[HTN]=
+ {
+-  { 0, 0-1, 0-1, 0,  0, htd33},
++  { 0, ~0u, ~0u, 0,  0, htd33},
+   { 1, 2-1, 2-1, 0,  7,htd01},
+@@ -556,3 +556,3 @@ const HUFFMANCODETABLE MPEGaudio::ht[HTN]=
+   { 3, 3-1, 3-1, 0, 17,htd03},
+-  { 4, 0-1, 0-1, 0,  0, htd33},
++  { 4, ~0u, ~0u, 0,  0, htd33},
+   { 5, 4-1, 4-1, 0, 31,htd05},
+@@ -566,3 +566,3 @@ const HUFFMANCODETABLE MPEGaudio::ht[HTN]=
+   {13,16-1,16-1, 0,511,htd13},
+-  {14, 0-1, 0-1, 0,  0, htd33},
++  {14,~0u,  ~0u, 0,  0, htd33},
+   {15,16-1,16-1, 0,511,htd15},
index 71994bba5a986467f1ed1eb8e91776d221768100..5e39a34756f7cc81b1ece23a1e7ee381238f035e 100644 (file)
@@ -24,6 +24,7 @@ S=${WORKDIR}/${MY_P}
 
 src_prepare() {
        epatch "${FILESDIR}"/${P}-smpeg2-config.patch
+       epatch "${FILESDIR}"/${P}-gcc6.patch
        epatch_user
 
        # avoid file collision with media-libs/smpeg