app-arch/rpm2targz: update to EAPI=7
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 22 Mar 2020 09:10:50 +0000 (09:10 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 22 Mar 2020 09:13:27 +0000 (09:13 +0000)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
app-arch/rpm2targz/rpm2targz-9.0.0.5g-r1.ebuild [new file with mode: 0644]

diff --git a/app-arch/rpm2targz/rpm2targz-9.0.0.5g-r1.ebuild b/app-arch/rpm2targz/rpm2targz-9.0.0.5g-r1.ebuild
new file mode 100644 (file)
index 0000000..f40eb7d
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert a .rpm file to a .tar.gz archive"
+HOMEPAGE="http://www.slackware.com/config/packages.php"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-arch/cpio"
+DEPEND=""
+
+src_compile() {
+       emake CC="$(tc-getCC)"
+}
+
+src_install() {
+       emake DESTDIR="${ED}" install # need explicit install line #397835
+       dodoc *.README*
+}