sys-apps/kexec-tools: drop old
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 4 May 2020 15:31:33 +0000 (17:31 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 4 May 2020 16:00:52 +0000 (18:00 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-apps/kexec-tools/Manifest
sys-apps/kexec-tools/kexec-tools-2.0.19-r1.ebuild [deleted file]
sys-apps/kexec-tools/kexec-tools-2.0.20.ebuild [deleted file]

index a318c88ab4885fbcad3406e169e5d2472ba2d1f0..7d82850e81a6b75508751c7897690f715c7630e4 100644 (file)
@@ -1,2 +1 @@
-DIST kexec-tools-2.0.19.tar.xz 292348 BLAKE2B c9827d77c82f11351086f4cdf4bacd076a03c744969952706ffd6f17395f28fba2437dac976e12e8e5648ca09fac6ff241daf9b8d3fee215519ded9f18441ff0 SHA512 68b15fe46f9633d55c5ae51a6e7114b0c66bd8f4fe81197f581121939a7b21990a2eea89a0961ac6eb7af364ba0d3981ea504df81c7b4cc0b288ca6ac896730f
 DIST kexec-tools-2.0.20.tar.xz 297476 BLAKE2B 7e29e7f7d85296dd3e614c45f14c27eca74ce4426d5de2d20387d89f2f63afed318d6157cc4001849a04bb83505bbae87c43d34683ebaf9a70f5f29e3979ade3 SHA512 3112b6202c1030705c53e3f65a2b58aec14d65333a35aad681d48b9f2bd1c51a2e05c985a1e5e867ab02f8a9c97708483d9d225619db7c6993676f1a242e2d99
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.19-r1.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.19-r1.ebuild
deleted file mode 100644 (file)
index ddde674..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic libtool linux-info systemd
-
-if [[ ${PV} == "9999" ]] ; then
-       inherit git-r3 autotools
-       EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git"
-else
-       SRC_URI="https://www.kernel.org/pub/linux/utils/kernel/kexec/${P}.tar.xz"
-       KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-fi
-
-DESCRIPTION="Load another kernel from the currently executing Linux kernel"
-HOMEPAGE="https://kernel.org/pub/linux/utils/kernel/kexec/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="booke lzma xen zlib"
-
-REQUIRED_USE="lzma? ( zlib )"
-
-DEPEND="
-       lzma? ( app-arch/xz-utils )
-       zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-CONFIG_CHECK="~KEXEC"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-2.0.4-disable-kexec-test.patch
-       "${FILESDIR}"/${PN}-2.0.4-out-of-source.patch
-)
-
-pkg_setup() {
-       # GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
-       export ASFLAGS="${CCASFLAGS}"
-}
-
-src_prepare() {
-       default
-       if [[ ${PV} == "9999" ]] ; then
-               eautoreconf
-       else
-               elibtoolize
-       fi
-       filter-flags '-mindirect-branch=thunk*'
-}
-
-src_configure() {
-       local myeconfargs=(
-               $(use_with booke)
-               $(use_with lzma)
-               $(use_with xen)
-               $(use_with zlib)
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_install() {
-       default
-
-       dodoc "${FILESDIR}"/README.Gentoo
-
-       newinitd "${FILESDIR}"/kexec.init-2.0.13-r1 kexec
-       newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
-
-       insinto /etc
-       doins "${FILESDIR}"/kexec.conf
-
-       insinto /etc/kernel/postinst.d
-       doins "${FILESDIR}"/90_kexec
-
-       systemd_dounit "${FILESDIR}"/kexec.service
-}
-
-pkg_postinst() {
-       if systemd_is_booted || has_version sys-apps/systemd; then
-               elog "For systemd support the new config file is"
-               elog "   /etc/kexec.conf"
-               elog "Please adopt it to your needs as there is no autoconfig anymore"
-       fi
-}
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.20.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.20.ebuild
deleted file mode 100644 (file)
index 6f01ce7..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic libtool linux-info systemd
-
-if [[ ${PV} == "9999" ]] ; then
-       inherit git-r3 autotools
-       EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git"
-else
-       SRC_URI="https://www.kernel.org/pub/linux/utils/kernel/kexec/${P/_/-}.tar.xz"
-       [[ "${PV}" == *_rc* ]] || \
-       KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-fi
-
-DESCRIPTION="Load another kernel from the currently executing Linux kernel"
-HOMEPAGE="https://kernel.org/pub/linux/utils/kernel/kexec/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="booke lzma xen zlib"
-
-REQUIRED_USE="lzma? ( zlib )"
-
-DEPEND="
-       lzma? ( app-arch/xz-utils )
-       zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P/_/-}"
-
-CONFIG_CHECK="~KEXEC"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-2.0.4-disable-kexec-test.patch
-       "${FILESDIR}"/${PN}-2.0.4-out-of-source.patch
-)
-
-pkg_setup() {
-       # GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
-       export ASFLAGS="${CCASFLAGS}"
-}
-
-src_prepare() {
-       default
-       if [[ "${PV}" == 9999 ]] ; then
-               eautoreconf
-       else
-               elibtoolize
-       fi
-       filter-flags '-mindirect-branch=thunk*'
-}
-
-src_configure() {
-       local myeconfargs=(
-               $(use_with booke)
-               $(use_with lzma)
-               $(use_with xen)
-               $(use_with zlib)
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_install() {
-       default
-
-       dodoc "${FILESDIR}"/README.Gentoo
-
-       newinitd "${FILESDIR}"/kexec.init-2.0.13-r1 kexec
-       newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
-
-       insinto /etc
-       doins "${FILESDIR}"/kexec.conf
-
-       insinto /etc/kernel/postinst.d
-       doins "${FILESDIR}"/90_kexec
-
-       systemd_dounit "${FILESDIR}"/kexec.service
-}
-
-pkg_postinst() {
-       if systemd_is_booted || has_version sys-apps/systemd; then
-               elog "For systemd support the new config file is"
-               elog "   /etc/kexec.conf"
-               elog "Please adopt it to your needs as there is no autoconfig anymore"
-       fi
-}