dev-python/ws4py: fix $S
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 21 May 2020 14:54:53 +0000 (16:54 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 21 May 2020 14:54:53 +0000 (16:54 +0200)
Closes: https://bugs.gentoo.org/723188
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-python/ws4py/ws4py-0.5.1-r1.ebuild
dev-python/ws4py/ws4py-9999.ebuild

index 558868593e6016566227669488b245267865e3d3..3e590bb7984c68c19b677622e335ac6578d4f6d0 100644 (file)
@@ -10,13 +10,16 @@ EAPI=7
 PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="threads(+)?"
 
+MY_PN="WebSocket-for-Python"
+
 inherit distutils-r1
 if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
+       EGIT_REPO_URI="https://github.com/Lawouach/${MY_PN}.git"
        inherit git-r3
 else
-       SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/Lawouach/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 arm ~x86"
+       S="${WORKDIR}/${MY_PN}-${PV}"
 fi
 
 DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"
index 21de5cde42da53fdb672dddbe53a0309db718948..3e590bb7984c68c19b677622e335ac6578d4f6d0 100644 (file)
@@ -10,13 +10,16 @@ EAPI=7
 PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="threads(+)?"
 
+MY_PN="WebSocket-for-Python"
+
 inherit distutils-r1
 if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
+       EGIT_REPO_URI="https://github.com/Lawouach/${MY_PN}.git"
        inherit git-r3
 else
-       SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~x86"
+       SRC_URI="https://github.com/Lawouach/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 arm ~x86"
+       S="${WORKDIR}/${MY_PN}-${PV}"
 fi
 
 DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"