www-servers/nginx-unit: Post-stabilisation cleanup
authorRalph Seichter <github@seichter.de>
Thu, 7 May 2020 16:19:30 +0000 (18:19 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sun, 10 May 2020 22:41:39 +0000 (00:41 +0200)
Remove obsolete ebuild now that version 1.17.0 has been stabilised.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Ralph Seichter <gentoo@seichter.de>
Closes: https://github.com/gentoo/gentoo/pull/15684
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-servers/nginx-unit/Manifest
www-servers/nginx-unit/nginx-unit-1.8.0.ebuild [deleted file]

index 5d20a9a4eccd962f9d94f30dc4343d7e18dc1b06..fdb40a579efdc2d8893dea17f20ada5f66d47abc 100644 (file)
@@ -1,2 +1 @@
 DIST nginx-unit-1.17.0.tar.gz 726928 BLAKE2B d171f2f818302cb0f491ccc3ca93596ee52817647cf1f2f176ebed075cb1dd5772f133d9e925075fe72d826a63b4c4debddace8784612196ebe6b6655d70571b SHA512 4175fc6dd84ad8a3bbdc117d3ce0c7a11c708a7a204ade0bb40f5606f6923e351bb1a8f1f8394c09cdf12fdc20bc927920412dc4b41d3141f76482db047c4bed
-DIST nginx-unit-1.8.0.tar.gz 511226 BLAKE2B e396b27954840a5f1ad3a4cd9501a5e5fe769a754c51043da784a2c4596e6acc33089f495bf412a0db086e5c715a51292c7dece004a6512564421a431b6c339e SHA512 1d0ad05343ff70aff4c6e221a36c20df95fa2e2262ae5c69963a9bcb9ef883151e8a2fa9fef29f43ac5489aa5cbb3e9dfd10cf5e7f6d7a98742b490ebf3a0413
diff --git a/www-servers/nginx-unit/nginx-unit-1.8.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.8.0.ebuild
deleted file mode 100644 (file)
index ac86712..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=(python3_{6,7})
-
-inherit python-single-r1
-
-MY_P="unit-${PV}"
-DESCRIPTION="A dynamic web and application server"
-HOMEPAGE="https://unit.nginx.org"
-SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64"
-MY_USE="perl python ruby"
-MY_USE_PHP="php7-2 php7-3"
-IUSE="${MY_USE} ${MY_USE_PHP}"
-REQUIRED_USE="|| ( ${IUSE} ) python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="perl? ( dev-lang/perl:= )
-       php7-2? ( dev-lang/php:7.2[embed] )
-       php7-3? ( dev-lang/php:7.3[embed] )
-       python? ( ${PYTHON_DEPS} )
-       ruby? ( dev-lang/ruby:= )"
-RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
-       use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
-       ./configure \
-               --control=unix:/run/${PN}.sock \
-               --ld-opt="${LDFLAGS}" \
-               --log=/var/log/${PN} \
-               --modules=$(get_libdir)/${PN} \
-               --pid=/run/${PN}.pid \
-               --prefix=/usr \
-               --state=/var/lib/${PN} || die "Core configuration failed"
-       for flag in ${MY_USE} ; do
-               if use ${flag} ; then
-                       ./configure ${flag} || die "Module configuration failed: ${flag}"
-               fi
-       done
-       for flag in ${MY_USE_PHP} ; do
-               if use ${flag} ; then
-                       local php_slot="/usr/$(get_libdir)/${flag/-/.}"
-                       ./configure php \
-                               --module=${flag} \
-                               --config=${php_slot}/bin/php-config \
-                               --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
-               fi
-       done
-}
-
-src_install() {
-       default
-       diropts -m 0770
-       keepdir /var/lib/${PN}
-       newinitd "${FILESDIR}/${PN}.initd" ${PN}
-}