dev-perl/MooseX-Getopt: Bump to version 0.740.0 re bug #675719
authorKent Fredric <kentnl@gentoo.org>
Tue, 16 Jul 2019 00:13:28 +0000 (12:13 +1200)
committerKent Fredric <kentnl@gentoo.org>
Tue, 16 Jul 2019 00:14:13 +0000 (12:14 +1200)
Upstream:
- Fix tests broken by Getopt::Long::Descriptive 0.103.0
- move exit() call to a higher scope to allow 'after' method-modifiers
  on 'print_usage_text'
- Fix 'init_arg' when used in combination with an underscored attribute
  read from a configuration file.

Bug: https://bugs.gentoo.org/675718
Bug: https://rt.cpan.org/Public/Bug/Display.html?id=125992
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/MooseX-Getopt/Manifest
dev-perl/MooseX-Getopt/MooseX-Getopt-0.740.0.ebuild [new file with mode: 0644]

index 3596a08883ba5c334791f9aa03710776eba1b9d0..ec23f89eca3a56d3d5a0958ea042c4b01f88b5d3 100644 (file)
@@ -1 +1,2 @@
 DIST MooseX-Getopt-0.71.tar.gz 54544 BLAKE2B f4aecb2d0d34b1bd665b7aca5cdfc5c612f17cfc7999f2c52105ed3e3d80c71ee5e7824bc279a1791896f812ff6ccb322faa3319bd5396340469deac5df47709 SHA512 cc3c24e545dcd9459340699552b38927a0f2fe114dcaab1201033b501397522e1faf5fbf09f4fa45df006035871e5fab058c682c000f5e1f1a576b4a36a9ed5c
+DIST MooseX-Getopt-0.74.tar.gz 58129 BLAKE2B f2a451d819c53a725a73cefb0ad3d76c94090d25d927b11fd76a92c8534bca56fb5112e298d57caa7fb81e8b6c26f273f06efda74f55db20b384029bcd9b8ca1 SHA512 3b7ea4f75192c62936f7838809a4a3facc4ccc38fb9db5affd46d07273ac1ffadd5ddb0882fe5d29870bf4b8c816916febdc3748747223c837fc87c65faa60ac
diff --git a/dev-perl/MooseX-Getopt/MooseX-Getopt-0.740.0.ebuild b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.740.0.ebuild
new file mode 100644 (file)
index 0000000..ed41d81
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.74
+inherit perl-module
+
+DESCRIPTION="A Moose role for processing command line options"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+       virtual/perl-Carp
+       >=virtual/perl-Getopt-Long-2.370.0
+       >=dev-perl/Getopt-Long-Descriptive-0.88.0
+       >=dev-perl/Moose-0.560.0
+       >=dev-perl/MooseX-Role-Parameterized-1.10.0
+       virtual/perl-Scalar-List-Utils
+       dev-perl/Try-Tiny
+       dev-perl/namespace-autoclean
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       >=dev-perl/Module-Build-Tiny-0.34.0
+       test? (
+               virtual/perl-File-Spec
+               dev-perl/Module-Runtime
+               virtual/perl-Module-Metadata
+               >=dev-perl/Path-Tiny-0.9.0
+               dev-perl/Test-Deep
+               >=dev-perl/Test-Fatal-0.3.0
+               >=virtual/perl-Test-Simple-0.880.0
+               dev-perl/Test-Needs
+               dev-perl/Test-Trap
+               >=dev-perl/Test-Warnings-0.9.0
+               virtual/perl-if
+       )
+"