gnome-extra/gnome-documents: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 14 Nov 2015 10:15:00 +0000 (11:15 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 14 Nov 2015 13:45:12 +0000 (14:45 +0100)
Package-Manager: portage-2.2.24

gnome-extra/gnome-documents/Manifest
gnome-extra/gnome-documents/gnome-documents-3.18.2.ebuild [new file with mode: 0644]

index 0adbe0caa9818482f4429a020361c6f9edcd394c..cce7e283b8f4d160b200b54e2aeed4dc402ccb40 100644 (file)
@@ -1,2 +1,3 @@
 DIST gnome-documents-3.16.3.tar.xz 2280484 SHA256 4ea2ee08421fc0d43e4daa5937f008fced477f06666c6862fe0b87fc756d633d SHA512 dadcff3e8df1d481fc80573bf4a501eb91bece367e31977c0af1754b294dc032760c182739b19e7d358cf0f9d707782f0b26124eae4dba05f72805d0d303b683 WHIRLPOOL b930d53d3df3cff2ce55b0cf4a050e686c07a3157b51ebc76bcdc146b5ba6a95922655b1ca4175f5d3220f6989b5e68c2a29f92d17735b6d2bd9489dba4edac0
 DIST gnome-documents-3.16.4.tar.xz 2282220 SHA256 f3c5374dc8be3fae77141251809b3defac5827e400f713c9a3a0b1e95e5fb895 SHA512 1f0c0344603418e6b2449f880db17ac69a4b16bf79bbb027e7a041707cecf5b8981ec7adb39783f94ac11fe1fafce8ce02f28a0b4d5f4f6a06080c2d0e23f3a0 WHIRLPOOL f94c1cb6923c16409195919c8d342bfb65c98f0117f66bf6446229e058f8dedaf5352bd6113d724880d45cd483d01acd312460a56d41ef8d84791a35125d1829
+DIST gnome-documents-3.18.2.tar.xz 2297404 SHA256 850ddaf3366549bbe0696c2ec3a36faf16438b387b8e9cb7812c7d5266a74cd4 SHA512 638ed9020d5204e5587e2241040fff6aa62fc7f1afd50e035f50c5038d1b72038233f2f1a001d89bf45f210344f83790a2c2358a24ee9692a30f3b663dd81dbd WHIRLPOOL 8a08fd0155ec60da7d1276ee4f25be2f7e3ddcfe09e9f0785dd952ab2a58bdcddcaaea8f83c558689613eb914d848209a24f8fd9e7a1e37ead1e208306523272
diff --git a/gnome-extra/gnome-documents/gnome-documents-3.18.2.ebuild b/gnome-extra/gnome-documents/gnome-documents-3.18.2.ebuild
new file mode 100644 (file)
index 0000000..3a0b4fc
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A document manager application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Documents"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+# Need gdk-pixbuf-2.25 for gdk_pixbuf_get_pixels_with_length
+COMMON_DEPEND="
+       >=app-misc/tracker-1:=
+       >=app-text/evince-3.13.3[introspection]
+       dev-libs/gjs
+       >=dev-libs/glib-2.39.3:2
+       >=dev-libs/gobject-introspection-1.31.6:=
+       >=dev-libs/libgdata-0.13.3:=[gnome,introspection]
+       gnome-base/gnome-desktop:3=
+       >=media-libs/clutter-1.10:1.0
+       >=media-libs/clutter-gtk-1.3.2:1.0[introspection]
+       >=net-libs/gnome-online-accounts-3.2.0
+       >=net-libs/libsoup-2.41.3:2.4
+       >=net-libs/libzapojit-0.0.2
+       >=net-libs/webkit-gtk-2.6:4
+       >=x11-libs/gdk-pixbuf-2.25:2[introspection]
+       >=x11-libs/gtk+-3.15.5:3[introspection]
+       x11-libs/pango[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+       media-libs/clutter[introspection]
+       net-misc/gnome-online-miners
+       sys-apps/dbus
+       x11-themes/gnome-icon-theme-symbolic
+"
+DEPEND="${COMMON_DEPEND}
+       dev-libs/libxslt
+       >=dev-util/intltool-0.50.1
+       dev-util/itstool
+       virtual/pkgconfig
+"
+# eautoreconf requires yelp-tools
+
+src_prepare() {
+       # Prevent sandbox violation, https://bugzilla.gnome.org/show_bug.cgi?id=758097
+       sed -i -e '/-rm -f $(appdir)\/org.gnome.Books.data.gresource/d' data/Makefile.{am,in} || die
+       gnome2_src_prepare
+}