app-misc/mosquitto: bump to version 1.5.3
authorLucas Ramage <ramage.lucas@protonmail.com>
Thu, 25 Oct 2018 00:57:11 +0000 (20:57 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Fri, 26 Oct 2018 00:34:41 +0000 (20:34 -0400)
Closes: https://bugs.gentoo.org/668436
Signed-off-by: Lucas Ramage <ramage.lucas@protonmail.com>
Package-Manager: Portage-2.3.49, Repoman-2.3.11
Closes: https://github.com/gentoo/gentoo/pull/10221
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
app-misc/mosquitto/Manifest
app-misc/mosquitto/mosquitto-1.5.3.ebuild [new file with mode: 0644]

index 66c09e49408012b8491d380f7ef6a1783248197c..ddfa4ca971522ce9faa73204ae68122fe8742c6c 100644 (file)
@@ -1,2 +1,3 @@
 DIST mosquitto-1.4.14.tar.gz 365596 BLAKE2B 92bcb1fd9e67711d6ce8db5e767be31a1321866205cf4cad684d8b77a8b14a2eaf5e4367a74d5dd8f814f0d229dc77ce878879632c0c34c6a23f7975bf6ae8c7 SHA512 dc75a971354f87deeb79f32435acfae9bc561a1a24a75ee4940a35176ff91758071930d2105d8dee2a090e07527dbfaa5692bece67e03cc87e8b4b8b46f846c2
+DIST mosquitto-1.5.3.tar.gz 425844 BLAKE2B d868dd67cd86e57f6af8e5556e0cee520f60cac4f16a24ceeec163acf5663339908d77304b7e70898ef5afaeeabb57c2a2857df297600180e1b9db6f2bf990b1 SHA512 8aa4f85914316c2dc08908a649779946ab33b23ea669c6f7eed0d8a1af7ae26381cfe1a50c32d220658f8693ef6a86045690824af4b7ca0271426ff3455e7796
 DIST mosquitto-1.5.tar.gz 419614 BLAKE2B d405e1e4f967f1030229a2e64793b84a3c8dc356a3b8d95a9bfc50a623cdb79517bbcfda87275f23c44002f3a41a20db58fed5a33d2c7d63da95e0d6d15951bb SHA512 29b82bc0c6510fa5062cb43c06bd91ce5223be5689cba077df8b2cb5ac377cb125b8a8bb292b53bcec0d4b186977c25c3ecdd8c92d4ed996fde07f8c759c0668
diff --git a/app-misc/mosquitto/mosquitto-1.5.3.ebuild b/app-misc/mosquitto/mosquitto-1.5.3.ebuild
new file mode 100644 (file)
index 0000000..44c2e14
--- /dev/null
@@ -0,0 +1,101 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit systemd user toolchain-funcs python-any-r1
+
+DESCRIPTION="An Open Source MQTT v3 Broker"
+HOMEPAGE="https://mosquitto.org/"
+SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="bridge examples +persistence +srv ssl tcpd test websockets"
+
+REQUIRED_USE="test? ( bridge )"
+
+RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
+       srv? ( net-dns/c-ares )
+       ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       websockets? ( net-libs/libwebsockets )"
+
+_emake() {
+       LIBDIR=$(get_libdir)
+       emake \
+               CC="$(tc-getCC)" \
+               LIB_SUFFIX="${LIBDIR:3}" \
+               WITH_BRIDGE="$(usex bridge)" \
+               WITH_PERSISTENCE="$(usex persistence)" \
+               WITH_SRV="$(usex srv)" \
+               WITH_TLS="$(usex ssl)" \
+               WITH_WEBSOCKETS="$(usex websockets)" \
+               WITH_WRAP="$(usex tcpd)" \
+               "$@"
+}
+
+pkg_setup() {
+       enewgroup mosquitto
+       enewuser mosquitto -1 -1 -1 mosquitto
+}
+
+src_prepare() {
+       default
+       if use persistence; then
+               sed -i -e "/^#autosave_interval/s|^#||" \
+                       -e "s|^#persistence false$|persistence true|" \
+                       -e "/^#persistence_file/s|^#||" \
+                       -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
+                       mosquitto.conf || die
+       fi
+
+       # Remove prestripping
+       sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\
+               client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die
+
+       python_setup
+       rm test/{broker,lib}/ptest.py || die
+       python_fix_shebang test
+}
+
+src_compile() {
+       _emake
+}
+
+src_test() {
+       _emake test
+}
+
+src_install() {
+       _emake DESTDIR="${D}" prefix=/usr install
+       keepdir /var/lib/mosquitto
+       fowners mosquitto:mosquitto /var/lib/mosquitto
+       dodoc readme.md CONTRIBUTING.md ChangeLog.txt
+       doinitd "${FILESDIR}"/mosquitto
+       insinto /etc/mosquitto
+       doins mosquitto.conf
+       systemd_dounit "${FILESDIR}/mosquitto.service"
+
+       if use examples; then
+               docompress -x "/usr/share/doc/${PF}/examples"
+               docinto "/usr/share/doc/${PF}"
+               doins -r examples
+       fi
+}
+
+pkg_postinst() {
+       if [[ -z "${REPLACING_VERSIONS}" ]]; then
+               elog "The Python module has been moved out of mosquitto."
+               elog "See https://mosquitto.org/documentation/python/"
+       else
+               elog "To start the mosquitto daemon at boot, add it to the default runlevel with:"
+               elog ""
+               elog "    rc-update add mosquitto default"
+               elog "    or"
+               elog "    systemctl enable mosquitto"
+       fi
+}