kde-frameworks/purpose: Add USE dolphin, RDEPENDs, ecm_find_qmlmodule
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 17:18:01 +0000 (18:18 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 17:24:18 +0000 (18:24 +0100)
Add USE dolphin and missing RDEPEND
Upstream commit 8d7123896b988384c756cb948667ea08b86533f4

Bug: https://bugs.gentoo.org/700830
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-frameworks/purpose/files/purpose-5.64.0-ecmqmlmodules.patch [new file with mode: 0644]
kde-frameworks/purpose/metadata.xml
kde-frameworks/purpose/purpose-5.64.0-r2.ebuild [new file with mode: 0644]

diff --git a/kde-frameworks/purpose/files/purpose-5.64.0-ecmqmlmodules.patch b/kde-frameworks/purpose/files/purpose-5.64.0-ecmqmlmodules.patch
new file mode 100644 (file)
index 0000000..2cae935
--- /dev/null
@@ -0,0 +1,32 @@
+From 7ba45fdc2b9d0c599497495387a70d3d5ddad5c4 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 8 Dec 2019 15:26:18 +0100
+Subject: [PATCH] Use standard ECMQMLModules
+
+---
+ src/plugins/CMakeLists.txt | 9 ++++-----
+ 1 file changed, 4 insertions(+), 5 deletions(-)
+
+diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
+index fa4637b..9790e76 100644
+--- a/src/plugins/CMakeLists.txt
++++ b/src/plugins/CMakeLists.txt
+@@ -19,11 +19,10 @@ function(kpackage_install_package dir component root)
+            PATTERN Messages.sh EXCLUDE)
+ endfunction()
+-set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake" ${CMAKE_MODULE_PATH})
+-include(QMLModules)
+-find_qmlmodule(Ubuntu.OnlineAccounts 0.1)
+-find_qmlmodule(org.kde.kdeconnect 1.0)
+-find_qmlmodule(org.kde.kquickcontrolsaddons 2.0)
++include(ECMQMLModules)
++ecm_find_qmlmodule(Ubuntu.OnlineAccounts 0.1)
++ecm_find_qmlmodule(org.kde.kdeconnect 1.0)
++ecm_find_qmlmodule(org.kde.kquickcontrolsaddons 2.0)
+ find_package(KAccounts)
+ find_package(KF5KIO ${KF5_DEP_VERSION} REQUIRED)
+-- 
+2.24.0
+
index 69186b245f38e6d805f4ff1287d17ea12c818979..6732ba335acaf949c0c280b2e17647fd6532e663 100644 (file)
@@ -6,6 +6,7 @@
                <name>Gentoo KDE Project</name>
        </maintainer>
        <use>
+               <flag name="dolphin">Enable support for sharing files from <pkg>kde-apps/dolphin</pkg></flag>
                <flag name="kaccounts">Enable support for system-wide defined KAccounts</flag>
        </use>
 </pkgmetadata>
diff --git a/kde-frameworks/purpose/purpose-5.64.0-r2.ebuild b/kde-frameworks/purpose/purpose-5.64.0-r2.ebuild
new file mode 100644 (file)
index 0000000..409caa0
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dolphin +kaccounts"
+
+DEPEND="
+       >=dev-qt/qtdeclarative-${QTMIN}:5
+       >=dev-qt/qtgui-${QTMIN}:5
+       >=dev-qt/qtnetwork-${QTMIN}:5
+       >=dev-qt/qtwidgets-${QTMIN}:5
+       >=kde-frameworks/kcoreaddons-${PVCUT}:5
+       >=kde-frameworks/ki18n-${PVCUT}:5
+       >=kde-frameworks/kio-${PVCUT}:5
+       >=kde-frameworks/kirigami-${PVCUT}:5
+       dolphin? ( >=kde-frameworks/knotifications-${PVCUT}:5 )
+       kaccounts? (
+               >=kde-apps/kaccounts-integration-19.04.3:5
+               net-libs/accounts-qt
+       )
+"
+RDEPEND="${DEPEND}
+       >=dev-qt/qtquickcontrols-${QTMIN}:5
+       >=dev-qt/qtquickcontrols2-${QTMIN}:5
+       >=kde-frameworks/kdeclarative-${PVCUT}:5
+       kaccounts? ( net-libs/accounts-qml )
+"
+
+# requires running environment
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${PN}-5.64.0-ecmqmlmodules.patch" ) # git master
+
+src_configure() {
+       local mycmakeargs=(
+               $(cmake_use_find_package dolphin KF5Notifications)
+               $(cmake_use_find_package kaccounts KAccounts)
+       )
+
+       ecm_src_configure
+}
+
+pkg_postinst(){
+       ecm_pkg_postinst
+
+       if ! has_version "kde-misc/kdeconnect[app]" ; then
+               elog "Optional runtime dependency:"
+               elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
+       fi
+}