dev-ros/sound_play: Bump to 0.3.2.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 8 May 2018 12:05:49 +0000 (14:05 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 8 May 2018 12:22:21 +0000 (14:22 +0200)
Package-Manager: Portage-2.3.36, Repoman-2.3.9

dev-ros/sound_play/Manifest
dev-ros/sound_play/sound_play-0.3.2.ebuild [new file with mode: 0644]

index e44fb07f407fcd4df5fe5d3e63852b8c1c1ffad9..186e8633cd458a6a60ab23bbc7e512cc83b91969 100644 (file)
@@ -1 +1,2 @@
 DIST audio_common-0.3.1.tar.gz 184749 BLAKE2B 3404c419962dc6bf22f63a36bf43cb8d7509244f84a2a3407717ee31f1be56e22e352e714310d69b9ee280d0aa1d13df3cdbcbb0a42a47f3d3408cb42e3ddfa5 SHA512 3accd7d0ff91ce70c643747ae0b4db4c11bbd6b93dda02c1934d23a900b6bf286e72461e296fe1e0d49ebadd99c3ca1b042db8feddc9cca2ae70a0caccea7147
+DIST audio_common-0.3.2.tar.gz 187214 BLAKE2B 12708d58c9ba28477f5f42866310aedaba66f647b20064b41675befe63f095a08b077e6082ec7969db7c626eb7576ac108c4a1f492083b3554b93ac0c56a6415 SHA512 bdd28e05f45b177c22e64bba168a722ff9b7bdf72f9b11a86bcc08ba7f9edfed83793f87aa5479354dff10a5834f13363f6986a63f60c0af965006b837df1508
diff --git a/dev-ros/sound_play/sound_play-0.3.2.ebuild b/dev-ros/sound_play/sound_play-0.3.2.ebuild
new file mode 100644 (file)
index 0000000..c6c2efd
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS node that translates commands on a ROS topic (robotsound) into sounds"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/roscpp
+       dev-ros/rospy[${PYTHON_USEDEP}]
+       dev-ros/roslib
+       media-libs/gstreamer:1.0
+       dev-ros/audio_common_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+       dev-python/gst-python[${PYTHON_USEDEP}]
+       app-accessibility/festival
+       media-libs/gst-plugins-good:1.0
+       media-libs/gst-plugins-base:1.0
+"