games-puzzle/gnome-taquin: bump to 3.34.4
authorMart Raudsepp <leio@gentoo.org>
Sun, 22 Mar 2020 16:23:25 +0000 (18:23 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 22 Mar 2020 16:49:15 +0000 (18:49 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
games-puzzle/gnome-taquin/Manifest
games-puzzle/gnome-taquin/gnome-taquin-3.34.4.ebuild [new file with mode: 0644]

index d83d9bac9e138d0183cde0349a0f5762b241410b..62602f01d6cad904fa3a491806e8238d1bcd04b4 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-taquin-3.32.0.tar.xz 5234188 BLAKE2B c302cc24385161d7cb12f77a8278399ef0e08322912d1afa0fce92a8064ccf8320de570f5995a84354db92179f697e31a600ad2144d44d9d006f539a1135428b SHA512 b874d38ca3a3d31fecabe0f0661d0410e69d744e06192c037f8a71da11e963e2a557780eb1a7fe9c75dd64a969b8d39c3ec1318ffe6a99c4248652ff5a416418
+DIST gnome-taquin-3.34.4.tar.xz 5242780 BLAKE2B 9763d77f77ddfc0c283663be22258b7baa2529f0d3efc05200f1735ca8766008451e648b6fb7b15e4f06887a6c040b5f25e5e63291b00036180a134854bcc57c SHA512 15da9ebc8c1aa89b350132efe034b977d96a62e686d01cfe8547b47541f1c2d30d564ba3eed35e3c80818835703cf4f33552d373908a2e8287c3982c041d7eef
diff --git a/games-puzzle/gnome-taquin/gnome-taquin-3.34.4.ebuild b/games-puzzle/gnome-taquin/gnome-taquin-3.34.4.ebuild
new file mode 100644 (file)
index 0000000..7d60672
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Move tiles so that they reach their places"
+HOMEPAGE="https://wiki.gnome.org/Apps/Taquin"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-libs/glib-2.40.0:2
+       >=media-libs/gsound-1.0.2
+       >=x11-libs/gtk+-3.22.23:3
+       >=gnome-base/librsvg-2.32.0:2
+"
+# libxml2+gdk-pixbuf required for glib-compile-resources (xml-stripblanks and to-pixdata)
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-libs/libxml2:2
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       x11-libs/gdk-pixbuf:2
+       $(vala_depend)
+       media-libs/gsound[vala]
+       gnome-base/librsvg:2[vala]
+"
+
+src_prepare() {
+       xdg_src_prepare
+       vala_src_prepare
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}